Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #1
i was driving my car at 70mph today and heared a noise that sounded like i ran over something. afterwards every so often a clunking noise would show up, as i got farther the clunking noise would appear over any bump big or small and it sounded more like crunching a soda can. the noise sounds like the left rear.

im really worried if i should be driving it or not, im thinking its an axle or diff because of the inital loud noise. but ive never heard anything like this and the noise is not continuous.
engines, brakes, steering are all fine. when i push down on the car at the corners nothing makes any noises.

anyone have any ideas? im not at my garage or else id take a wheel or two off.
 

·
Registered
1984 €uro 300D NA
Joined
·
758 Posts
Can you duplicate the noise with the car parked by rocking up and down the rear?
 

·
Registered
1979 280CE
Joined
·
6,118 Posts
yep sounds like you broke a sway bar link, they're plastic. I'd recomend using a W115 link, they're metal....
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #5
lol i dont even want to talk about what happened cause i never want to think about it again but i found the culprit.

for some reason left side parking brake was rubbing the rotor even when disengaged. i removed the shoes and springs earlier in the week.

today after my first post i take off the rotor again and i hear a *ping*, a chuck of metal dropped onto the driveway. it was the shoe lever. from being loose and not attached to anything in the drum anymore the whole assembly cracked itself off the cable and started to enjoy life swimming around my rotor.

its defiantly not going back in its pretty banged up. and i have not the slightest clue how i would be able to reinstall a new one because the cable is pressed onto the lever. im guessing i need the whole cable up to the Y adjuster cause it comes as one piece.
 

·
Registered
1982 Mercedes 300D Turbo Diesel
Joined
·
141 Posts
I get a similar noise from the right rear but it doesn't start until I've been driving for a while at about 60+ mph. Weird thing is that if I bring it down to a stop, put it in neutral and back into drive the sound goes away. Gonna put her on ramps this week and see if I can find the culprit.
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #7
even after i thought i had this noise fixed i hear a similar noise getting off the highway after about 20 minutes this morning, not fun. but it was doing 75-80 mostly.
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #8 (Edited)
update, i knew i would be posting in this again so here it is, left side axle has a ton of play side to side and rotates off axis when you spin the wheel on a lift.

i also need to replace the diff, the pinion bearing is the costant noise ive been hearing. couldnt find anything searching here id appreciate any threads or pics for this.
 

·
Registered
1979 280CE
Joined
·
6,118 Posts
I just checked and mine will also slide side to side, must be normal....
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #10
I just checked and mine will also slide side to side, must be normal....
its only on one side, right side axle is very tight i tried to move it plenty of times.
did you check both? an axle will usually have snap rings to keep this from happening but i dont know the differences between manufacturers and front vs rwd. so possibly it could be normal but the rotation was not, it also made a small knock in the air if you spun it slowly by hand. which is what ive been hearing if i take it past 75 and decelerate.
 

·
Registered
1996 E320, 2005 Toyota Camry
Joined
·
1,810 Posts
noise

Recently, I was going nuts listening to a banging noise in the back of my W116. Took it to the shop, they replaced a badly worn anti-sway "thingie" and that stopped it! Maybe your noise comes from that part being worn down.
Hemersam
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #12 (Edited)
Recently, I was going nuts listening to a banging noise in the back of my W116. Took it to the shop, they replaced a badly worn anti-sway "thingie" and that stopped it! Maybe your noise comes from that part being worn down.
Hemersam
my noise is not at low speeds, and my bearing isnt audible until 30mph. i hear a squeak in the front but thats because the shocks look older and more worn then the car.

btw this is pretty much the nail in the coffin for my 81 coupe, it will definatly get parted out now for the diff and the other 50 things i need. sad day.
 
1 - 12 of 12 Posts
Top