Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
00 C-230, 04 C-240
Joined
·
468 Posts
Discussion Starter #1
The rear suspension is making noise on rough surfaces. The noise sounds like the muffler is hitting against something, but I checked & could not find anything loose or out of place.

Anyone seen this problem before?

Could it be suspension bushings?
 

·
Registered
Joined
·
8 Posts
This original post is three years old. I haven't lurked around here much but found this site again. I have been experiencing banging in the back of my wifes 98 C230 for a few years going over bumps. Bought it at 68k miles and it now has 120k. I have narrowed down the banging to what I believe is one or all of the four subframe mounts in the rear. Has anyone had these rubber mounts fail and replaced them? I am thinking of tackling this next summer.
 

·
Registered
Joined
·
8 Posts
No, not the muffler hangers. There is a subfram in the back of the car that is mounted to the body with four rubber mounts. The rear suspension is attached to the rear subfram. There are two mounts just inside the front part of the rear wheels and two more on either side of the trunk.

Hopefully this link works. Its part one of a writeup on replacing the mounts on a 190.

http://www.dot7design.com/mercedes/W201_190D_subframe1.pdf
 

·
Registered
96' C220
Joined
·
1,275 Posts
Good Link

The link worked fine. It's probably very similar to ours. I'll bet if you put your seats down and rode back there over some bumps you could really feel where it's coming from. It could be those rubbers or something else in the suspension. I'm sure it's one of those you gotta be there to tell noises.

The rubber on these cars is going to all need replacing soon. Most people won't bother. I just finshed changing the Motor and Tranny mounts on ours today. The right side was really BAD the other two were ok but original, with 110K Miles on them.

Good Luck & Welcome to the pages of the Forum!:thumbsup:

C as in 220
 

·
Registered
Joined
·
8 Posts
No fold down rear seat but I was thinking of crawling into the trunk and have my wife drive up and down our street with me in the trunk going over some bumps hoping i could zero in on the location. Hopefully she lets me out of the trunk.
 

·
Registered
13 GLK350, 03 c320 wagon, 90 560sec
Joined
·
787 Posts
Try tightening your swaybar end links. Thought they may look tight, you may find they have come loose, even if visual inspection looks fine. This will cause a clunking sound when going over bumps.
 

·
Registered
Joined
·
8 Posts
I have grabbed the rear sway bar endlinks before and have triued to yank on them to see if there is any play with the car loaded on its wheels and also with the suspension hanging with the car jacked up but they were tight. I will check the tightness of the nuts. i was thinking of having someone slowly jack up the body while I try to wiggle the endlink. Maybe with the suspension loaded and hanging there is tension on the endlinks and any looseness will show up when I unload them by slowly jacking the body.
 
1 - 8 of 8 Posts
Top