Mercedes-Benz Forum banner
1 - 3 of 3 Posts

·
Registered
'84 300tdt
Joined
·
9 Posts
Discussion Starter · #1 ·
I just replaced my front brakes and rotors and have a serious humming noise that kind of sound like a low flying jet airplane. First thing i did was loosen the seal on my wheel bearings and i thought it fixed it until 20 miles later it started again. so i loosened them some more and thought it was fixed but started again. Once it starts making the noise it continues and gets louder if I'm going fast. I'm starting to loose my mind adjusting the bearings over and over again. I figure it should be tight enough where the rotor turns freely but doesn't have any play when you shake it. The pads also seem tight on the rotors...
 

·
Registered
'84 300tdt
Joined
·
9 Posts
Discussion Starter · #2 ·
Luckily, I have a mechanic buddy that took it for a test drive and recommended taking off the rotors and checking the torque of the hub fasteners. Hopefully it works...
 

·
Registered
'84 300D/ dakota benz trk. Sold... miss it. "88 260E '91 190E 2.6 '89 Volvo 240DL "85 300D
Joined
·
1,252 Posts
Luckily, I have a mechanic buddy that took it for a test drive and recommended taking off the rotors and checking the torque of the hub fasteners. Hopefully it works...
did you turn the rotors? did you inspect the wheel bearings while doing the brakes? or is all you did, replace the pads? it sounds like you may have pitted wheel bearings or the race is bad. i would take it all back down and clean and inspect the bearings and race. if good to go, re-pack bearings and replace wheel seal, tighten as you stated to where it will turn easily by hand but not spin like a fan blade.
 
1 - 3 of 3 Posts
Top