Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1996 SL500
Joined
·
4 Posts
Discussion Starter #1
Hello Benzworld!

Thanks to everyone for contributing to a great site!

Here's the brief skinny, details to follow.
1996 SL500
Nothing works in the lower center console.
No pwr windows, no pwr mirror, no roll bar, no soft top, no cigarette lighter.

Soft top and roll bar button are lit up during beginning of a drive.

gray with blue stripe should be constant pwr to all switches. When tested it appears to be a ground.

Is there a fuse/ fusible link under the dash that could be burned out, or is the AST module causing this?

More details:
My father and I recently acquired a 1996 SL500, gave it a serious detailing and away we went. Had some issues at thanks to dads impatience with windows and top outta sync. I finally got it all working again after following the manual and instructions here. He then had the roll bar up when I grabbed it for a spin. We stopped at idle after a brief but brisk trip on a dirt road. Roll bar light began to flash and things went down hill from there.

Initially we were able to disconnect the battery over night and raise the windows, and roll bar and top; but not all at once and not consistently. After several days of this we can no longer get anything to move.

My thought is that the roll bar was not raised fully and the bumpy dirt road drive caused the roll bar sensors to think it was in an accident and now it needs to be rebooted. Or some fuse/link somewhere other than the trunk or hood has failed. All fuses in those locations have been checked and all are OK.

Thanks for any and all help!
Scott
 

·
Premium Member
2015 Jaguar XF R Sport Twin Turbo, 1992 500sl Pano, 1999 CBR 1100XX, Super BlackBird, Jaguar X Type
Joined
·
4,818 Posts
Mine is a 92 model, the top, roll bar and windows didn't work. The windows would work with door open but not closed. The problem was *6 fuse under the hood. My fuses were the old silver alloy type I replaced with new copper type and no problems since. The horn and Rev lights are also on that fuse check if they work. Not sure if the 96 isthe same layout.
Presuming the battery is in good condition (a must have on this car) I would start cleaning and changing related fuses (also the ones in the trunk) and checking connections before lashing out too much cash.
 

·
Registered
94 SL600, 89 Jag XJS conv, 85 Daimler Princess, 97 993 63 Avanti 16 Lincoln MKZ hybrid 16 Silverado
Joined
·
720 Posts
How hard did you drive the car? did the roll bar deploy?
The old fuse materials has certainly been an issue for some in the forum, however the old materials still work for my 94. I have changed out about half, because of shorting the system during light conversion and my inept hands!
Since you have a light in the top button, then you must have that wiring connected, so I would look to the other factors in, window, top and roll bar controls. The bundle of wiring that supplies the center console is easy to follow. From your comments I assume you have had the console apart with the connectors to the switches disconnected. The connectors are hardy, but could they have become dismantled?
My history with old cars and electrical issues have helped the hair color conversion process, I hope you and your father don't!;)
 
1 - 3 of 3 Posts
Top