Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I inadvertently changed the coding string on my 2008 E320 Bluetec and now the car won't start.

Any help would be greatly appreciated.
 

·
Purple Moderator
99 ML430, 00 ML320, 05 E500 4matic Wagon
Joined
·
22,004 Posts
How did you change the string and with what programming device did you do it with?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
I didn't actually change anything but opened the variant coding according to factory data and pressed f2 instead of f1. The car was running at that time. Ignition off and back on as requested and changes must have been made. I currently have the battery charging and will attempt to start again but I am at work now.

I have a C4 that I was utilizing
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
I went into control units, drive, cdi 4 cdi 5 common rail diesel injection, control unit adaptations, variant coding, variant coding due to factory data. Again I didn't change any values but it had me wait turn the ignition off and back on.

Do you know what these values are, what they mean and what I should do?
 

·
Registered
W219 320CDI -07 W220 320CDI -01 W210 270CDI -01 EX: W211 320CDI -04
Joined
·
1,086 Posts
Oh I believe you reset your engine ECU to factory values then... can't see why that would prevent starting, unless engine ecu is not visible in can. You might try to check can configuration first.

Be careful what you do next, you may not be able to revesible actions without help of factory connection OR other softwares (and their pro user)... I can't help much because I just recently found that Xentry cars are pretty difficult to do anymore easy codings, because almost everything will need SCN... it was way more easier with DAS system.

Unfortunately no way of knowing what all ecu options are in your car, I believe you will need now to do initial setup of your ecu. And I truly hope that action won't need online access to SCN code string (it might well need that, because in Vediamo CRD unit changes usually need seed codes too).

You could try to find a fellow familiar with Vediamo or Monaco to code your ecu back to life. (Do you have those softwares installed? I am just about learning very basics of these, their usage is much more complicated than xentry, and much much easier to make harm than Xentry)

Last action if nothing helps is get you car towed to dealer and ask them upload the ecu...

Edit: I recommend try everything in simulation mode first (in DAS or Xentry) before going real action. It is true that not all option are possible in sim mode, but sometimes it helps.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
The fob still unlocks and locks the doors, somehow I de programmed the fob for starting?
 

·
Registered
W219 320CDI -07 W220 320CDI -01 W210 270CDI -01 EX: W211 320CDI -04
Joined
·
1,086 Posts
Try find out if starting is authrorized... or where permission signal stops...
 

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG
Joined
·
3,657 Posts
Das -> control unit -> body -> EZS (or EIS) -> Live data -> Drive authorization

Post a pic of the live data.


Clearly you must have changed the variant coding somehow, because obviously because the car doesn't start.

Then go to:

Das-> control unit -> Powertrain -> CDI 4 -> Live data -> drive authorization.

Also read the codes in the ECU and post.

In the same menu, go to control unit adaption -> view coding

Post a pic of that.
 
1 - 11 of 11 Posts
Top