Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
1995 SL500 / 2003 C32/ 2000 S430
Joined
·
58 Posts
Discussion Starter #1
my 2000 S430 lost power to the window switch,seat adjuster, outside mirrors controls only on the drivers side, all the other area in the car work OK. Any one know where to look for this problem?
 

·
Registered
1995 SL500 / 2003 C32/ 2000 S430
Joined
·
58 Posts
Discussion Starter #3
Klaus9000, I checked all the fuses under the hood and they were OK. Is there another fuse panel some were else?
 

·
Registered
2000 S430 156k (11/12)
Joined
·
507 Posts
Make sure F13 40amp fuse is good under the hood left side fuse box, 8th fuse from the front of the car, amber color.

3rd fuse box is under the rear seat, you could expose it by popping the rear right courtesy light under the seat.
 

·
Premium Member
1. S320, Model 2000, clr chalcedony blue. 2. 730Li, model 2005, clr titanium silver
Joined
·
35 Posts
front passenger seat heater of my s320 is not heating though the seat back is working well. if someone can guide I ll appreciate. regards.
 

·
Registered
Current 2017 GLE350, 2007 S550, 2002 S430, 1998 ML320 Deceased 74 240D, 92 400E, 97 E420, 13 GLK350
Joined
·
1,915 Posts
Make sure F13 40amp fuse is good under the hood left side fuse box, 8th fuse from the front of the car, amber color.
+1 for xexpo's recommendation. Looks like all functions described go thru this fuse.
 

·
Registered
2000 and 2003 W220 S500
Joined
·
930 Posts
and if you replace the Door Control Module and it does the same thing over again, it's most likely water getting into the door.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,667 Posts
yes, this happened to me. change door control module
 
1 - 9 of 9 Posts
Top