Mercedes-Benz Forum banner

21 - 26 of 26 Posts

·
Registered
1998 E320 Base Sedan, 175k
Joined
·
12 Posts
Measure voltage on the plus post (under the hood, driver side, under a lid marked with "+"), and the ground stud nearby. These are the charging posts for the battery. If no 12V there, you have a loose connection on one of the battery terminals, or the negative disconnect strap on the wall of the rear passenger seat under a lid.
“Negative disconnect strap” is what exactly? And if those charging posts (or at least the positive for that matter) didn’t have connection the battery charger wouldn’t have charged the battery or even made a guess as to the percentage of battery life when charging through those posts, would it not?
 

·
Registered
1998 E320 Base Sedan, 175k
Joined
·
12 Posts
Measure voltage on the plus post (under the hood, driver side, under a lid marked with "+"), and the ground stud nearby. These are the charging posts for the battery. If no 12V there, you have a loose connection on one of the battery terminals, or the negative disconnect strap on the wall of the rear passenger seat under a lid.
I don’t have a multimeter yet whenever I can actually do any of these suggestions you’d be getting responses that had actual information but I don’t and until then it’s all rather speculative besides visually inspectable parts/wires/harnesses
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,678 Posts
I don’t have a multimeter yet whenever I can actually do any of these suggestions you’d be getting responses that had actual information but I don’t and until then it’s all rather speculative besides visually inspectable parts/wires/harnesses
Let us know when you get the multimeter.

Check the tightness of the connection.
 

·
Registered
1998 E320 Base Sedan, 175k
Joined
·
12 Posts
Let us know when you get the multimeter.

Check the tightness of the connection.
Well that’s never been undone since I’ve owned it and has never become loose before unless those two times years ago were due to that than I don’t see it being the likely cause, and the connections to the battery itself? Those are tight, as they never weren’t and I checked again the other day and just as tight as ever
 
21 - 26 of 26 Posts
Top