Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
E-350/2010 4-MATIC (E-320/2000 R.I.P.)
Joined
·
378 Posts
Discussion Starter #1 (Edited)
no codes but... NOT READY?
I was doing the adaptive transmission reset, because car was running a little sluggish....while doing so I still had the OBD hooked up. Before I had ran it no codes I/M was fine, after I did the trans reset, I got this:

NO CODES
BUT..
CAT NOT READY
EVAP NOT READY
2AIR NOT READY
02S NOT READY
H02S NOT READY
EGR NOT READY

:confused: Any ideas???
 

·
Registered
2014 E350 4Matic sedan, 68K miles (purchased Jan 2017)
Joined
·
855 Posts
someone with more expertise will have to chime in here but i believe this is normal until a drive cycle is completed after resetting the transmission.
 

·
Registered
E-350/2010 4-MATIC (E-320/2000 R.I.P.)
Joined
·
378 Posts
Discussion Starter #3
Thanks for the reply fju2112 I was thinking that as well...may have to drive a couple miles to clear, I'm hoping! I'll keep my fingers crossed :D

I am planning on changing AT fluids this weekend also...have 89K and not sure it was before I purchased the car...It had 58k when I got it.
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
You reset the engine computer at the same time. I don't know if that's how it should be, but it is what happened.

If you reset any engine codes, you will also encounter a "Not Ready" status on all of the I/M readings. Drive the car normally for a few days and they should all go to "Ready."
 

·
Registered
1994 E320 Wagon,1999 E320 Wagon,2000 E 320 Wagon, MGB Track/Rally, ,1988 300E ,more....
Joined
·
6,019 Posts
And

if you erased any codes even if you had none it will trip most of the emissions I/M not ready codes.It will take a bunch of drive cycles to get them all back to ready status or search for my generic drive cycle procedure I posted here a while back.You will need a long stretch of good road and someone looking out for ole smokey but boy is it a heck of a lot more fun and quicker then waiting to complete 40 drive cycles:thumbsup:
ohlord:bowdown:
 

·
Registered
E-350/2010 4-MATIC (E-320/2000 R.I.P.)
Joined
·
378 Posts
Discussion Starter #6
Thanks Matt L and Rob...um um... I mean Ohlord ;)

I think you gave me that info before regarding the quick drive cycle reset don't know that I'll be able to pull it off though...unless its really late at night!!! Hmmmm maybe.... :D
 
1 - 6 of 6 Posts
Top