Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2001 SLK 320
Joined
·
31 Posts
Discussion Starter #1
I purchased an Alpine OEM CD Changer, and I followed the installation instructions found on the slk32.com web site. After installation, my head unit reports "No CD Changer." Anyone experience this problem? If so, how is it corrected? Also, where does the CD Changer mount in the boot? There does not appear to be any really good location for it.
 

·
Registered
93 300SD, 99 S600
Joined
·
11 Posts
No CD Changer

An earlier post said that the car has to be brought to the dealer to have the tuner programmed to recognize the CD Changer. Seems like the Good Folks at Mercedes is doing more and more to make it necessary to visit them more often!!!
 

·
Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,242 Posts
I purchased an Alpine OEM CD Changer, and I followed the installation instructions found on the slk32.com web site. After installation, my head unit reports "No CD Changer." Anyone experience this problem? If so, how is it corrected? Also, where does the CD Changer mount in the boot? There does not appear to be any really good location for it.
Your head unit does NOT need reprogramming to recognize the changer. There could be a few problems:

1) bad changer. find someone with a Mercedes changer and buy him lunch, then pull his changer out and connect it to your system, then see if it works

2) power connections... is the power connector fully seated in the changer? check the fuse. when you put a magazine in the changer, does it eject OK? if it ejects, your power is fine

3) fibre optic... since there's a bunch to do with the fibre optic cables, you probably messed up. check that the loop is correct. do you have an OEM phone? if so, you need to take this into account and hook the loop up correctly

Hope that's helpful.

-s-
 

·
Registered
2001 SLK 320
Joined
·
31 Posts
Discussion Starter #4
NO CD Changer

I have power; so, the problem must be in the cable pairing. I understand that the clear cable is the input and the red is the output. I have one clear cable and one red cable in each connector. The keys within the connector will allow only one way to seat them--red on top and white on the bottom. These cables are marked HU In and HU OUT at the CD Changer and similarly marked CDC IN and CDC OUT at the Head Unit. What should I be doing differently?
Andy
[B)]
 

·
Registered
'05 SL500, '88 560SL
Joined
·
132 Posts
well i had everything on mine hooked up correctly and it said no cd changer so i decided...

well i had everything on mine hooked up correctly and it said no cd changer so i decided to take to dealer, the guy said everything was hooked up correctly, so he hooked it up to the computer and got it working, but my 2002 s430 just plugged in and worked, so i guess it just depends on the vehicle
 
1 - 5 of 5 Posts
Top