Mercedes-Benz Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Sometimes when I start my SLK 230 from '98 I don't get any boostpressure at all. This happens without any reasonable cause.
It won't come back if I just turn the engine off or leave it for some minutes. It seems like the supercharger won't work at all.

Most often everything works fine, but this has happened a couple of times now.

What could be wrong?

How do I reset the ECU? Loosing the battery connector?

Can I clean the MAF myself?

//
thanks for your help.

Jonas
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #2 · (Edited)
I just took my SLK for a ride again and when I started I had no boost pressure, meaning the supercharger did not engage. I drove to the side and idled for a minute, then I slowly reved the engine up and by 200 rpm I could feel a distinct *thump*. Is this *thump* the supercharger clutch engaging? When I drove of the supercharger worked fine! Strange to me...

Is the activation of the supercharger dependent on the coolant temp? I get the feeling that the engine is running slightly warm. Normaly it stays at 80 deg C (a quarter up the scale) but at times it goes up to the third pin, with just about some 20 deg C left to the max.
 

·
Registered
C2D SLK32K
Joined
·
514 Posts
Check the intercooler pump
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #4 ·
How can I check the intercooler pump? Where is it located, what should I look for?

BR
Jonas
 

·
Registered
C2D SLK32K
Joined
·
514 Posts
Jonas_Gothenburg said:
How can I check the intercooler pump? Where is it located, what should I look for?

BR
Jonas

Do a search for intercooler pump and you'll find a few threads on it.

Not sure about the 98 model though......Sounds like a Bazzle question.....lol
 

·
Registered
2002 SLK 32 AMG, bone stock. 1987 190E 2.3-16 valve (destroyed). 2005 E320 new toy.
Joined
·
14,926 Posts
There is no intercooler pump on the SLK 230's, they have an air cooled intercooler.:)

"Is the activation of the supercharger dependent on the coolant temp?"
Not normally, it sounds like the problem lies elsewhere. It could be a sensor failure.

"I get the feeling that the engine is running slightly warm. Normaly it stays at 80 deg C (a quarter up the scale) but at times it goes up to the third pin, with just about some 20 deg C left to the max."
Standard operating range for your engine is 80 to 100deg C. if your in that range you should be OK.
Jonas, please put your model and year SLK in your avitar, it makes it easier to help with problems........:)
 

·
Registered
C2D SLK32K
Joined
·
514 Posts
Bruce R. said:
There is no intercooler pump on the SLK 230's, they have an air cooled intercooler.:)

"Is the activation of the supercharger dependent on the coolant temp?"
Not normally, it sounds like the problem lies elsewhere. It could be a sensor failure.

"I get the feeling that the engine is running slightly warm. Normaly it stays at 80 deg C (a quarter up the scale) but at times it goes up to the third pin, with just about some 20 deg C left to the max."
Standard operating range for your engine is 80 to 100deg C. if your in that range you should be OK.
Jonas, please put your model and year SLK in your avitar, it makes it easier to help with problems........:)

I knew I shouldn't have tried to answer that question. Sorry for misleading you.....guess for me its the 10% rule.

10% rule = You have to be 10% smarter than the equipment your operating.

Sorry man..........I'll stick to the 32 questions....:eek:(
 

·
Registered
Golf R32 / Prev R170 SLK
Joined
·
6,821 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #9 ·
Hmm...so I'm in the right temp range then. Wonder what it could be.

Toook it for a spin later this night and before I drove off I reved the car slowly from idel to 2500 rpm. Precisely at 2000 rpm I hear the *thump* I tlked about earlier. This must be the SC clutch engaging. When I drove everything was in order.

Must try to find a test when things are not in order and do the same test again.

What you say is the coolant temp is not an issue for the SC engagement?

BR
Jonas
 

·
Registered
Joined
·
144 Posts
Clutch engages at 2000rpm, can be seen while looking at it and goosing the tthrottle cable. I would advise on checking for holes or leaks in your intake stream. Also, do you have oil contamination in your intake track? If so, you have a failed oil seperator, and may have damged your MAF.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #11 ·
As earlier discussed my supercharger kicks in very noticably at 2000 rpm. However when I drive I feel it engage almost immediate after I have put my foot on the throttle pedal. When I let the car drive on idle speed with automatic gear "Drive" choosen, it seems like the supercharger is "off", but as soon as I touch the pedal it seems to engage.

Is this correct behaviour for a SLK 230 from 1998?

BR
Jonas Nilsson
Gotheburg
Sweden
 
1 - 12 of 12 Posts
Top