Mercedes-Benz Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
82 300D, ISU Formula
Joined
·
225 Posts
Discussion Starter #1
Finally got my 82 300D back from the mechanic, after over a months wait. I had a 83 300SD engine and transmission put in, and the thing runs like new. The engine starts right up, moves at a great pace, and the transmission shifts like a dream, no delays, slipping or obnoxious clunks. Just one question though, at idle the whole car will shake fairly violently, almost like the engine is missing, but once I get past 1100 RPMs or so, it runs flawlessly. The engine will ease up on shaking if I put the car into neutral when stopped. It only shakes when completly stopped. Maybe the idle is set too low? its at about 800RPM. Oh yeah, when I had the engine done, it got new fuel filters, new timing chain and tensioner, new motor mounts, the valves were resurfaced and adjusted. I also put a little Diesel treatment into the tank, maybe it will help.
 

·
Registered
90 300 SE ,85 300 GD
Joined
·
1,574 Posts
Might Try These Resources

www.germanusedcars.com, Hemmings Motor News, www.auroraaw.com, and autosportsunlimited.com. And finally, run an ad in the STAR, www.mbca.org.
 

·
Registered
Mercedes 300d
Joined
·
20 Posts
My 300d did the same thing. Are your injector tubes leaking. Also did they purge all the a...

My 300d did the same thing. Are your injector tubes leaking. Also did they purge all the air out of the diesel system? My injector tubes were leaking causing a rough idle I took them off and put plumbers tape being carefull NOT to get the tape too high were it would be injested by the injector causing a clog.
 

·
Registered
300 d turbodiesel
Joined
·
52 Posts
shaky idle is probably a vacumn problem... i adjusted my vacumn so that the locks have to be done manually, etc... but the shakes are gone
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top