Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
W124 300D Auto Saloon
Joined
·
3 Posts
Discussion Starter #1
Hi everybody,

Bought my first ever benz, a 1992 300D Auto, in dark grey colour (not sure of exact colour) and have to say its the best car ever! Its got 150K on the clock but the steering wheel and hole in drivers bolster say more like 250K!

Ive driven old Golf's, BMW's, fords, toyotas, hondas and many others but nothing as enjoyable, comfortable or satisfying as this!

Unfortunately there are lots of things that dont work, ive tried searching this forum and many others but am still confused as there seem to be lots of potential solutions...maybe there is something connecting them all...

things that dont work :eek::

Air Con - compressor does not engage - old system R12

Rear head rests don't lower

Cruise control

All interior switch lights, dash and center console - except speedo/rev/fuel area

Speedo needle wobbly and inaccurate by up to 10mph at higher speeds compared to GPS, fuel needle not accurate(ran out of juice on motorway)

reading lights/selecting switch - only works when door is open

auto extendable aeriel

individual heater controls - when one is hot, both sides turn hot


Guys I really appreciate any help you could give me, even if its something small, I really want to get this 124 back to full working order, but it may take some time as I will try to do much as possible myself!

Thanks in advance!
 

·
Registered
2013 E350 sedan, 2013 E350 cab, 1993 400E sold,1999 ML320
Joined
·
2,436 Posts
Some of your issues relate to others by looking at it. The A/C is the charge probably a leak normally expensive to fix the coil core in the car which is the weak point of the system.

Headrests are probably the switch or fuse, to check if your getting power back there and its not the unit pull the liner in the trunk against the gas tank and voltmeter while someone presses the button.

For the instrument cluster the ground behind it gets dirty bad, pull out wires only thing holding it in(and age). The fuel gauge may be a bad sending unit, gonna have to tesyt the resistence on the sending unit while running, varying signal its the sending unit varying voltage its the dash ground issue.

The reading lights I am not sure of unless you try spinning you fuses that usually clears up alot of electrical gremlins like that. New fuses are made of copper and dont suffer the same corrosion issues the old fuses do.

The aerial, well if you have the original radio could be a few issues, but this can be tied to your reading lights. The radio those lights and antenna are on the same fuse.

The heat issue could be one of the control "pods" that is vacuum controled is gone bad but more likely has more to do with the A/C not being functional. It blows hard because no cold air to cool it off any other way because volatge regulator is air cooled by air going over it.

I hope this gives you a decent starting point, I had all the same issues.

Good Luck.
 

·
Registered
W124 300D Auto Saloon
Joined
·
3 Posts
Discussion Starter #3
Some of your issues relate to others by looking at it. The A/C is the charge probably a leak normally expensive to fix the coil core in the car which is the weak point of the system.

Headrests are probably the switch or fuse, to check if your getting power back there and its not the unit pull the liner in the trunk against the gas tank and voltmeter while someone presses the button.

For the instrument cluster the ground behind it gets dirty bad, pull out wires only thing holding it in(and age). The fuel gauge may be a bad sending unit, gonna have to tesyt the resistence on the sending unit while running, varying signal its the sending unit varying voltage its the dash ground issue.

The reading lights I am not sure of unless you try spinning you fuses that usually clears up alot of electrical gremlins like that. New fuses are made of copper and dont suffer the same corrosion issues the old fuses do.

The aerial, well if you have the original radio could be a few issues, but this can be tied to your reading lights. The radio those lights and antenna are on the same fuse.

The heat issue could be one of the control "pods" that is vacuum controled is gone bad but more likely has more to do with the A/C not being functional. It blows hard because no cold air to cool it off any other way because volatge regulator is air cooled by air going over it.

I hope this gives you a decent starting point, I had all the same issues.

Good Luck.

Appreciate your response macdrone, thanks for taking the time to help :thumbsup:

I have ordered copper replacement fuses so am waiting to replace the whole lot in one go!

Regarding the instrument cluster, I just need to take apart the area where the fan controls are, and I will be able to access the Ground pretty easy right?
 

·
Registered
W124 300D Auto Saloon
Joined
·
3 Posts
Discussion Starter #4
Finally replaced all the fuses with new copper ones, never ever use a company called autowirez.co.uk, they tend not to do anything once they have your money!:mad:

Anyway back to the car, the fuses did not make any difference to anything so I decided to take apart the centre console, I did find 2 ground connections behind the where the auto shifter is cleaned them but did not help.

I take it this is not the ground you were referring to?

Now the glow plug preglow light comes on after the car has been started up - new glow plugs or new relay......:confused:
 
1 - 4 of 4 Posts
Top