Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1995 E320 Wagon, 1998 C280 Sedan
Joined
·
71 Posts
Discussion Starter #1
Hi all -

After a year and a half with my 95 E320 wagon, I bit the bullet and bought my wife a 98 C280! It's bone stock, real clean and has only 81K on it with full records and CarFax. I've learned a ton about the W124 from these forums and look forward to learning and wrenching on the W202. Anything special I should pay attention to right away? Thanks in advance.
 

·
Registered
1995 C280 (165K mi)
Joined
·
1,595 Posts
Your model year was not affected by the crappy harness. at 80k miles you are still a baby. don't worry too much.
 

·
Moderator
2.3-16 | A3 2.0T | 986 Boxster
Joined
·
5,048 Posts
The harness shouldn't be a concern in '98. In your climate I'd look for premature rust on the body and lower control arms. I'd also check all the rubber parts in the suspension, steering and brakes because of the car's age. If you can maintain your 124, this car will be very similar.
 

·
Registered
1995 E320 Wagon, 1998 C280 Sedan
Joined
·
71 Posts
Discussion Starter #5
Thanks guys! I knew the W124 had the biodegradable wiring issue, glad to hear it's not too much a problem in the W202. Rust is a problem here in the belt, but this one shows very very little and a few ball joints were recently replaced. Don't know about the bushings yet, but it handled well so I'm not immediately worried about them.
 

·
Registered
1962 W111 220SE Coupe
Joined
·
2,289 Posts
Check your flex disc and service the trans fluid if it hasn't been done yet. Enjoy!
 
1 - 6 of 6 Posts
Top