Mercedes-Benz Forum banner

1 - 20 of 53 Posts

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #1
Hi all,

I wanted to create a new thread on a recently acquired 03 w220 S600 LWB saloon I bought.

It was previously enthusiast owned by a member here then sold in Oct 18. The guy that bought it did put a few £k into it having ABC hoses replaced and servicing but generally speaking didn't really look after it too well. He had it tuned to 578hp and 910nm and shortly thereafter it developed a misfire. He tried to get it diagnosed which cost him £400 in the process but they couldn't pin point the problem and he elected to sell it as "spares or repairs" as he was "done with it".

I bought it sight unseen from England and had to shipped over to Ireland.

I was also on holiday at the time so It was a sleepless 3+ weeks until it got home. I was impressed by the overall condition of the car.

The misfire issue was resolved by a rebuilt left coil pack, 24 NGK plugs and all new insulators. The misfire is gone and the car goes like a rocket now.

Lots of pics to come later when I get home:)

So far I fixed the misfire, changed the oil early and properly detailed the exterior. There is work and issues I would like to address soon though:

1: At 143k miles approx. the car has a vibration that comes and goes when at idle. Normally worse when cold. I dont believe this is a misfire but rather knackered engine mounts. Need to take a closer look and check the full history of invoices the car came with to see if they were ever changed. I suspect not.

2: Renew both cam cover gaskets

3: both front fenders are rusted so I need to have them replaced and some minor rust on the rear arches repaired.

4: A rattle at the front of the motor. This appears to be the idler pulleys. So far I ordered 3x INA idler pulleys and I intend to get those replaced this weekend to see if it helps. It already has a new fan belt and the tensioner doesn't look too old.

5: I notice the car lamps inside appear to fluctuate brightness wise when running. I had this before on a w220 and it was a failing rectifier in the alternator. I want to pull the alternator and have my local specialist rebuild it at the same time as doing the pulleys.

6: Change all fluids and filters throughout the car.

I bought it with no MOT and it passed MOT here already needing nothing. Some underbody shots to get started

20190916_184431.jpg 20190916_193156.jpg 20190916_193203.jpg 20190921_122654.jpg
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #2
The wheels needed some TLC with wire wool and autosol followed by a thorough cleaning

20190916_181700.jpg 20190929_094310.jpg 20190929_112156.jpg 20190929_112328.jpg 20190929_112446.jpg 20190929_112550.jpg
 

·
Registered
2007 W164 ML320CDI Sport & 2002 W220 S280
Joined
·
60 Posts
Been reading your other threads on the car, I bought my220 I have as an experiment to see if I would get the use out of it and also see what they are like to work on.
The long term plan being to jump to a LWB600 TT or 63, either 220 or 221. I've been keeping an eye on autotrader but funds aren't there at the moment and hopefully the "B" word doesn't mess things up completely in terms of importing from the UK to Ireland which is already a complete rip off. Depending on how this one goes I'm thinking about selling the Boxster S in the spring as either of these woudl offer similar thrills but with the ability to carry more than one other person.

Best of luck and I'll be following this thread.
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #4
Been reading your other threads on the car, I bought my220 I have as an experiment to see if I would get the use out of it and also see what they are like to work on.
The long term plan being to jump to a LWB600 TT or 63, either 220 or 221. I've been keeping an eye on autotrader but funds aren't there at the moment and hopefully the "B" word doesn't mess things up completely in terms of importing from the UK to Ireland which is already a complete rip off. Depending on how this one goes I'm thinking about selling the Boxster S in the spring as either of these woudl offer similar thrills but with the ability to carry more than one other person.

Best of luck and I'll be following this thread.
Good to see someone else from Ireland on here! I had been reading your S280 threads also. If you are ever in Tyrone you are welcome to check out this S600! I also have my own Star diagnostics should you ever need the S280 checked out
 

·
Registered
2003 S430
Joined
·
2,423 Posts
You might want to discuss the alternator rebuild with your specialist before you decide to pull it - he might not be enthusiastic about a large, complex water-cooled unit.

How certain are you that the problem is not a failing battery?
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #6
You might want to discuss the alternator rebuild with your specialist before you decide to pull it - he might not be enthusiastic about a large, complex water-cooled unit.

How certain are you that the problem is not a failing battery?
I am blessed that one of the best alternator shops in the country is a mile from my house. He has done 12+ for me in the past few years and always excellent never a single issue. Very reasonable cost too.

I asked already and they rebuild plenty of water cooled units. Its simple - I will pull it, give it to them and they will bench test it. And when out put new bearings in it at a minimum which is what I want to do considering how inaccessible it is and the miles.

The battery In the car is new and I have tested it no issues. Very good Varta heavy duty battery. I have many other batteries I will also test in the car.

But my gut tells me the S600 alternator rectifier is going out.....
 

·
Registered
2007 W164 ML320CDI Sport & 2002 W220 S280
Joined
·
60 Posts
Good to see someone else from Ireland on here! I had been reading your S280 threads also. If you are ever in Tyrone you are welcome to check out this S600! I also have my own Star diagnostics should you ever need the S280 checked out
Much obliged for that offer, I was in Bangor at 8am this morning to beat the westlink mayhem. Back home for lunch and ahead of Lorenzo!!
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #8
OK ref my rough cold running engine. I googled more threads and noted this one:

https://mbworld.org/forums/s-class-w221/615338-s600-engine-running-loud-rough-when-cold.html

First observation – my S600 has recently had both the pulsation damper and gearbox mount replaced (Dec 2018). This suggests even before the misfire occurred and he threw in the towel, the PO was noting the vibrations issue.

The cure on that car in the thread above was replacement engine mounts. It then was said to run super smooth again.

I looked through all old invoices on my S600. No mention of it ever having had the 2x engine mounts replaced. I haven’t done any tests but I will this weekend once the heavy rain has blown over. At 143k miles the motor mounts really must be toast now. Hence I suspect I’ll need to order them from the dealer and get on with it sooner than later.
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #9
Here are photos of it taken when I first washed it. I did fully detail the exterior of the car last weekend but it rained the second I was done. So on Saturday I'll get proper photos of it :)

20190915_192952.jpg


20190915_193105.jpg
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #12
Gents - thankyou!

I'll get more pics this weekend. The paint came up amazing with clay and buffing. I'll explain what products I used also it really helped bring the paint back to life on it
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #14
Looks great! Lemfoeder engine mounts are same as oem and cheaper they are the supplier to mbz
Yes this is normally what I had always done. However last year I bought a pair of Lemforder Engine mounts for a w124 from Germany. When they eventually arrived the Lemforder box clearly stated Made in China. And the mount inside appeared sup par quality with zero brand markings on it. Very disappointing indeed. Lemforder have became a risky supplier I have heard of other recent cases with china made items from them too.

Febi and Meyle are mostly always poor quality / china too. Just becasue the box says "Meyle Germany" means nothing. Misleading. Febi bilstein is nothing to do with the Bilstein suspension group either, again misleading. Some Febi items are OE but it's a gamble. I did have a pair of brake shoes from Febi and happily the box said Made in Germany. But I also had pently of Febi parts which were made in china or had no country of origin on the box which basically means china too. Be careful out there folks! I have 11 benzes and been DIYing all my work for 15+ years. In recent years the parts suppliers have become risky at best and I won't put chinesium in my cars where I can avoid it. Although in years to come we may have no choice since MB have china parts now too for newer models...... Don't believe me? - https://forum.w116.org/test-drive/genuine-mercedes-parts-are-now-made-in-china/

In this case considering how much of a PITA the M275 mounts are to replace I will go dealer only for them.
 

·
W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
·
5,790 Posts
Hi,

Yeah, sign of the times, a Chinese Benz that uploads all it's Data for god knows who to get hold of and use against me !! .............

No thank you MB, I'll stick to my older models Mr MB :(
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #16 (Edited)
S600 took a notion to feel like running rough or about to stall today. It did this once before for about 1/4 mile to a filling station then when I came out fired up and drove normal again.... strange.

This time I used the in car voltage meter and take a look!


The last and very brief time it acted like this it had flickered the xenon headlamps off twice and back on again. This is what also made me suspect a charging issue. But it's so intermittent it is hard to tell. This is only the second time
 

·
W220 Moderator
S500 W220 SLK320 R170 C200 CDI W203 Peugeot Expert Van
Joined
·
5,790 Posts
Hi,

Does look like an intermittent Charging issue, check out the Pre Fuse Connections and Main Power Connections at Alternator etc before rebuilding the Alternator ;)

HTH,
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #18
Hi,

Does look like an intermittent Charging issue, check out the Pre Fuse Connections and Main Power Connections at Alternator etc before rebuilding the Alternator ;)

HTH,
Thanks yes I'll clean and tighten as many main electrical points I can put my hands on later tonight. And swap another battery in for giggles
 

·
Registered
2006 S600
Joined
·
229 Posts
Glad it went to a good home in the end, and it looks like your neighbour has good taste, too.

Yes, I didn't replace the engine mounts, and it did seem a bit rougher than my silver car, where I did change them. Difficult job. Definitely get a set of E-Torx ratchet spanners first. They're invaluable for these cars, and especially for the mounts, where you need all the help you can get.

JC - wait till you swing it round some fast corners - that car really handles for a luxo-barge. MB have been disguising it's talents for many years.

Nick
 

·
Registered
2007 E220CDI, 1990 300E-24V, 1987 W124 3.6 AMG build 1993 E500 W124, 94 320CE, 1997 W140 S280
Joined
·
1,301 Posts
Discussion Starter #20
OK I did do a test on the engine mounts as shown in other videos on you tube. Basically put the car in drive and give it a little gas and watch the engine to see if it moves too much.

They have hydraulic mounts as we know so the motor will always move a little. But as seen in my video linked below my S600's engine mounts are spanked as I suspected. At 1500rpm ish rev the engine lifts up on one side 2 - 3 inches and slaps back down. So I'll order mounts asap and let it rest until I tackle that fun job.

Thanks for the tips above Nick! And thanks again for you responding to my other messages before when I was looking at buying this car. Really cool of you most people wouldn't bother. The seller was not helpful so it was great to hear from you at the time

 
1 - 20 of 53 Posts
Top