Mercedes-Benz Forum banner
1 - 12 of 12 Posts

·
Registered
2005 E55 Designo
Joined
·
888 Posts
Discussion Starter · #1 ·
Its the same tired old story, it stopped opening the trunk handle yesturday & the door locks today. I simply pulled out the fuse until i can figure it out.
 

·
Registered
1992 300SD, 1986 300SDL, 1995 E420
Joined
·
884 Posts
On 92 models I believe the central locking pump is responsible for the trunk handle not the pse pump in the trunk. It is also responsible for a\c flap in the middle and reverse guides.
 

·
Registered
CLS350 C219 2006
Joined
·
582 Posts
Hi,

I think the info is incorrect. I got a '92 500SEL.
PSE (Under the right rear seat) does Trunk handle, lumbar, AC, central locking, reverse antenna, ...
Closing Assist Pump (in boot, behing passenger seat on left, beside tank) does that: closing assist, nithing else.

Cheers
 

·
Registered
2005 E55 Designo
Joined
·
888 Posts
Discussion Starter · #4 ·
Hi,

I think the info is incorrect. I got a '92 500SEL.
PSE (Under the right rear seat) does Trunk handle, lumbar, AC, central locking, reverse antenna, ...
Closing Assist Pump (in boot, behing passenger seat on left, beside tank) does that: closing assist, nithing else.

Cheers
exactly nubyOz. no burnt fuses.:confused:

door assist works as it should, but I heard a burbling under the boot latch near ext lock the day before the pse quit, i guessing vaccum hoses as a possible suspect.
 

·
Registered
CLS350 C219 2006
Joined
·
582 Posts
exactly nubyOz. no burnt fuses.:confused:

door assist works as it should, but I heard a burbling under the boot latch near ext lock the day before the pse quit, i guessing vaccum hoses as a possible suspect.
Mine is a acting a bit strange, need to close boot always twice, first time it comes up again too much.
Will take my latch apart next few days and post pics.

Cheers
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,293 Posts
Mine is a acting a bit strange, need to close boot always twice, first time it comes up again too much.
Will take my latch apart next few days and post pics.

Cheers
in 92-93 models, the PSE pump (under rear seat) does EVERYTHING, but door closeure (for trunk and 4 doors)
 

·
Registered
W140 Mercedes 500 SE, 1992, European, 440.000 km
Joined
·
3,961 Posts
On 92 models I believe the central locking pump is responsible for the trunk handle not the pse pump in the trunk. It is also responsible for a\c flap in the middle and reverse guides.
central locking pump (only one function of more) IS called PSE pump. it is under the rear seats. The another pump (close assist pump) is in the trunk. I can be 100% sure because my car has not any close assist pump at all ... and the trunk handle is working.
 

·
Registered
2005 E55 Designo
Joined
·
888 Posts
Discussion Starter · #9 ·
I ran a series of tests all the power points to the pse but nothing works.

I swapped the new pump motor (bosch)into the old hella pse unit & it ran, but didnt make anything work. (I did try the motor's wires in both directions)

Then replaced the pump motor back into the new bosch unit & it bolstered my seat for a fraction of a second & shut off not to work again.

Again no burnt fuses no smell, nothing.

I checked the motor & pump again to see if it failed & its ok, & works fine.

I'm almost convinced the circuit board and/or electronics failed on the new unit after less than one year of service...what a rip.

I'm going to ask autohaus AZ (bought from) if they can give me another one at a reduced price.

The only thing i didnt do is put the pse into another w140 to see if its my vaccum lines as suspect.
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,293 Posts
I am not sure if I missed something, but did you buy a new pump and take it apart?

WHY??
 

·
Registered
2005 E55 Designo
Joined
·
888 Posts
Discussion Starter · #11 ·
I am not sure if I missed something, but did you buy a new pump and take it apart?

WHY??
The brand-new pse was in my car & failed after only one year. That includes being in climate-controlled storage for six months.

I would like something that works at least a couple of years minimum for 309$ plus shipping:rolleyes:
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,293 Posts
if you bought the pump from AZ autohaus, you should have some sort of warranty on it.
 
1 - 12 of 12 Posts
Top