Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
s500
Joined
·
10 Posts
Discussion Starter #1
Hi,

I've a real pig of a problem, need some input from you techies out there. I've fitted a new Comand 2.0APS unit from the facelift 2002 S-Class into my '99 model. I've got everything working (with a lot of help!), ie Audio, CD's (changer and single player) Bose, Telephone, GPS, all the display features, dim at night etc. But I can't get a speed signal so the nav won't give directions! As far as I know the new Comand system gets a Can speed signal rather than separate wires like all the 2,0 and 2,5 prior models. I need either to access somewhere to input a speedsignal, or tap into the Can with a device to output a digital data stream to the Comand. Heavy stuff, I guess this will be a popular upgrade, if it can be made to work!! I think the new E-Class uses a similar comand unit.

HELP!!!!!!

Peter M. - UK
 

·
Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,242 Posts
Hi,

I've a real pig of a problem, need some input from you techies out there. I've fitted a new Comand 2.0APS unit from the facelift 2002 S-Class into my '99 model. I've got everything working (with a lot of help!), ie Audio, CD's (changer and single player) Bose, Telephone, GPS, all the display features, dim at night etc. But I can't get a speed signal so the nav won't give directions! As far as I know the new Comand system gets a Can speed signal rather than separate wires like all the 2,0 and 2,5 prior models. I need either to access somewhere to input a speedsignal, or tap into the Can with a device to output a digital data stream to the Comand. Heavy stuff, I guess this will be a popular upgrade, if it can be made to work!! I think the new E-Class uses a similar comand unit.

HELP!!!!!!

Peter M. - UK
You need a CANBUS simulator that will take the speed signal and output it on CANBUS. You can get one from [email protected] ... Steve (MBenzNL). I've seen him wire one up in a car.

-s-
 
1 - 2 of 2 Posts
Top