Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I just got a 1991 300E and my srs light keeps coming on and when it does my cars batery drains and will not start after i turn it off does any one know what is causing this and when it comes on my radio and other things act up and sometimes the car runs like poo if anyone can help me trouble shoot the problem i would greatly appriciate it
 

·
CH4S Admin , Outstanding Contributor
Joined
·
39,248 Posts
Welcome. To take advantage of all the forum features, please re visit the 'Welcome to the Forum' tutorial sticky on top of the W126 page, as well as the two DIY stickies. It will show how to search the forum, how to complete your profile with a location (makes it easier for members to offer advice), and even has a link to the Russian MB site where you can run a VIN#. The forum archive has a wealth of information, incl. write ups re your topic.

P.S. If your car is a W126 300SE/L you are in the right forum, if it's a 300E the W124 is the correct forum for you.
 

·
Premium Member
Joined
·
4,067 Posts
Bobby,

It sounds like you have some major issues with your electrical system.

I'd advise you to start with the basics:
- Is the alternator OK? No worn brushes, it puts out sufficient power?
- When was the battery last changed? Does it hold a charge in the car? Does it hold a charge if you remove it from the car?
- Check the main grund cable from the battery.
- Check the cables from the alternator to the battery.
- Check your Over Voltage Protection relay (OVP). Its a small box, dead center, between the two firewalls. It has a 10 amp fuse, but the relay could still be bad even if the fuse is intact.
- Change all old aluminium fuses for new copper-headed ones.

If the problems persist, start removing the fuses to track down which circuit drains the battery to narrow down the list of components to check.

Does the car have an aftermarket stereo? A hack installation job would be a prime suspect for problems.

I'm not ignoring the symptoms you listed. It's just that they're not very helpful in pinpointing the issues. As an example; you say the SRS light comes on which could mean the OVP relay is bad. However, if the OVP is bad you should also see the ABS light come on.

Good luck.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
the car holds a charge unless the lights on its not on all the time i just put in a optima red top battery changing the alt today it came with a extra so ill try it ill post more latter
 

·
Registered
Joined
·
1,607 Posts
The car holds a charge unless the light is on.
It's not on all the time.
I just put in a optima red top battery.
Changing the alt today.
It came with a extra so i'll try it.
I'll post more later.
I think this is how it was supposed to read (!?)

gr J
 
1 - 7 of 7 Posts
Top