Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
2000 e320 4matic
Joined
·
9 Posts
Discussion Starter #1
2000 e320 4matic

VIN: WDBJF82J5YX034704

Recently replaced my dead battery, and have most things back to normal, except for the Nav/CD Drive and my retrofitted bluetooth system, which is comprised of "VCS Module: A220 820 64 26" and "PSE: BQ682-0971" and MB V60 bluetooth puck with MB factory phone cradle.

V60 puck appears to have no power (after numerous reseats).

When I checked the COMAND DTC error codes after battery install, I saw the following:

SAE Code Type CNT State
N111 0 12 P (No data between D2B & D2N)
B1010 0 5 P (Low supply voltage)
B1762 0 14 A (Fault in CAN-Nav comm)
B1780 0 16 P (Fault in CAN-Instrument cluster comm)

After clearing error codes and using car for a day, and still having no Nav/CD or bluetooth, I only saw the following error code:

B1762 0 14 A (Fault in CAN-Nav comm)

When I checked for D2B Components, there was only a single entry:

Pos Actual Config
0 1C8 1C8 (COMAND)

And, when I did the D2B Wakeup Test, all of the entries were unchecked:

- CDC
- Telephone
- SBC
- Sound
- Mobile Phone

NAV COMAND panel says "Navigation cannot be activated". And, sometimes the CD COMAND panel shows "CD0" (but I only have a single CD Drive), other times it seemingly endlessly shows "Activating CD". Radio works fine. TEL COMAND panel shows "Error: No Phone".

Any ideas on what is going on and how to proceed? Did version coding get corrupted for VCS and/or Nav/CD? Did voltage issue during battery install fry my VCS or fuse(s)? Anyways, everything worked perfectly for years, until battery replacement. Any help here would be greatly appreciated!
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,979 Posts
1 - 2 of 2 Posts
Top