Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi Guys!

Picked up this 1994 E320 a few months ago and finally getting around to joining the community. Looking forward to getting to know you all and finding helpful info I'm sure I will need as I fix things here and there..

The W124 has always been one of my favorite car designs of all time, and while I would have loved a 500 or coupe version, I stumbled upon this MB dealership tech-owned 116k mi 2 owner facelift 3.2 which I couldn't say no to for a little over $2k. I love the idea of taking this classic design with me into the future as they become more and more sparse on the roads.. It's midnight blue on beige and runs (almost) perfect. (Aux fan stopped working, which seems common enough with lots of info to fix.) It always gives me joy to drive with the classic MB driving feel. Also found some cheap 17" monoblocks recently that will need refinishing I picked up from a 210 420 sport I plan to mount. :grin

Cheers,
Alex

Some pics:





 

·
W124 Moderator
Joined
·
12,585 Posts
Welcome Alex and congrats on acquiring your W124. Take a little time and read through our DIY sticky. There is a ton of info in that section that not only introduces the car to you, but has like links to problems/solutions on some of the more common issues that pop up with these cars. There's also links to the FSM (factory service manual).

Any maintenance history with the car?

Again, welcome

Jayare

Sent from my XT1710-02 using Tapatalk
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Thanks guys, will definitely check out the stickies. Re: maintenance I did receive a massive folder that covers everything starting from the early/mid 2000s when the car became about 10 years old.. so I was pretty happy about that.

The aux fan issue ended up being the fuses near the tail light module in the covered box behind the pill fuses. So drove around all weekend in the heatwave with AC blasting and no issues. Although when sitting in traffic I still get to the engage point for the high speed aux fan (105?), so wondering if thats normal or if if maybe the thermostat should be replaced to ensure it's fully opening.

Also ordered some OE MB rubber all-weather floor mats and dropping off the monoblocks to get refinished today.. will post some pics when all done.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
5 Participants
alex1984
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top