Mercedes-Benz Forum banner
1 - 2 of 2 Posts

·
Registered
1989 190e 2.6 1993 500sel (sold) 1995 S500 coupe (sold) 1994 S500 blk/blk
Joined
·
1,007 Posts
Discussion Starter · #1 ·
Upon starting my '89 190E 2.6, the RPM rises to just under 1000rpm and then falls quickly to 500RPM and begins to stall until I gently press the accelerator to above 1000RPM. Again the RPM falls to the point of stalling. I press the accelerator again and the RPM is sustained at about 900RPM and then as the engine warms the RPM falls to normal at about 520 RPM.

I don't drive the car much; in fact I've only driven it 400 miles in the last 9 months. Has any one here experienced this erratic RPM phenomenon and found a solution or a cause of it?

Any advice will be appreciated.
 

·
Registered
1989 190e 2.6 1993 500sel (sold) 1995 S500 coupe (sold) 1994 S500 blk/blk
Joined
·
1,007 Posts
Discussion Starter · #3 ·
Four things to check:
-Fuel
-Air
-ignition
-Electricial

Fuel:
-Fuel itself; it might need some moisture removal
-Pressure (adjust EHA and air fuel mixture)
-Cold start valve
-Pressure regulator
-fuel filter

Air:
-ICV
-ICV hoses
-Other vacuum hoses

Ignition:
-Spark plugs
-Distributor and cap
-Wires

Electric:
-OVP (Make sure it's ok and seated properly)
-Fuel pump relay (not likeley but worth checking)
Thanks! That's the advice I like to see.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top