Mercedes-Benz Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, recently I acquired a 1990 190E 2.6. I am new to BW and this is my first MB. I've had it for about six weeks and have only replaced the shocks, brakes, and battery. It was running great. I went on vacation for a week. On my return, the car started but ran really rough.. The next day it won't start at all - cranks strong though. I tried starter fluid into the intake and it still won't start. I've ordered new fuel filter and injectors. But, if it won't start using starter spray, I don't expect the filter and injectors to fix it. I will get new spark plugs too. Any suggestions or things to test? Thank you.
 

·
Registered
W124, 230E 5 speeds Manual, 1987
Joined
·
365 Posts
Hello, Most probably it is an ignition problem.
Since the car doesn't start with starting fluid that means a weak spark or no spark at all.
Start by checking the easiest things which are the distributor rotor and cap. inspect their condition, those should be replaced if they haven't been before anyway. Was it rainy when the car started running rough?
 

·
Registered
1989 W124 260E
Joined
·
3,571 Posts
Take a look in the dark to see if you can see any blue flash on the electrical ht parts ..because a faulty ht system is 85% of car problems ..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I will check the ignition stuff. I also plan to replace plugs and wires too (not sure of age).

No, when it started running rough, it was a nice, sunny day about 300pm. It was misty/wet when trying the starter fluid though. Thank you for your suggestions. I will post results. It may be a few days as I need to get parts and install them.

I still plan to replace injectors, fuel filter, and air filter along with plugs, wires, and ignition pieces (cap, rotor, etc.).
 

·
Registered
W124, 230E 5 speeds Manual, 1987
Joined
·
365 Posts
The cap and rotor could be easily visually inspected for any problem before replacing them, injectors as well could be tested. a bad injector will make the car run rough maybe but it won't prevent it from starting.
Check for vacuum leaks especially around the ICV Hoses and Intake boot.
Check your OVP Relay condition and fuse.
if you start throwing parts on your car you'll end up replacing many items that are still good and your problem may persist if not diagnosed correctly. Also, Make sure to Get the correct Non-resistor Spark plugs which are not easily available nowadays.
 

·
SuperModerator
1986/1990 W126
Joined
·
17,876 Posts
Hi, recently I acquired a 1990 190E 2.6. I am new to BW and this is my first MB. I've had it for about six weeks and have only replaced the shocks, brakes, and battery. It was running great. I went on vacation for a week. On my return, the car started but ran really rough.. The next day it won't start at all - cranks strong though. I tried starter fluid into the intake and it still won't start. I've ordered new fuel filter and injectors. But, if it won't start using starter spray, I don't expect the filter and injectors to fix it. I will get new spark plugs too. Any suggestions or things to test? Thank you.
Welcome to the forum. You're in the right place. Here's some info on filling out your profile and so on. FIND YOUR FORUM SECTION, COMPLETE PROFILE, Navigate...
 
1 - 7 of 7 Posts
Top