Mercedes-Benz Forum banner
1 - 10 of 10 Posts

·
Registered
ml 320 1998
Joined
·
213 Posts
Discussion Starter · #1 ·
Got in the car tonight ill admit i was going quite fast round a bend then i had 2 lights light up on my dash, BAS ESP ETS, i know there warning lights for not driving in the right conditions, but it was a warm sunny day, finished work drove home and the lights are still on, enyone got any idears how long they stay on for, or is there another problem?
regards.
restarted the vercle when i got home and theres just a clicking noise as if the batterys dead, im just charging the battery now, wats gone wrong?
 

·
Registered
2002 ML 500, 1994 Ford Explorer donated to Doctors without Borders
Joined
·
2,126 Posts
What model/Year?

The lights should go off as soon as the ESP is finished correcting. They should flicker, not stay on.
 

·
Registered
2012 ML350 4Matic Capri Blue Metalic w/ Almond interior
Joined
·
104 Posts
The ESP light may be on if you accidentally hit the button on the dash that turns it off - I did this once while driving at night. Try the button first. My 2cents
 

·
Registered
98ML320
Joined
·
1,278 Posts
An old battery that does not hold a full charge will cause some really weird electrical problems also.

How old is your battery.
 

·
Registered
Joined
·
11,243 Posts
Mercbear said:
The ESP light may be on if you accidentally hit the button on the dash that turns it off - I did this once while driving at night. Try the button first. My 2cents
I was under the impression that ESP will turn back on once you restart the car.
 

·
Registered
2012 ML350 4Matic Capri Blue Metalic w/ Almond interior
Joined
·
104 Posts
asianml said:
I was under the impression that ESP will turn back on once you restart the car.
It had happened to me after 2 weeks of ownership and being so new to the ML I immediately pulled over, grabbed the Manual and figured it out; never stopped engine, but it may do so. Thanks, AsianML :)
 

·
Registered
ml 320 1998
Joined
·
213 Posts
Discussion Starter · #7 ·
got a new battery today, ill keep you informed , any info on fitting a new battery would be appreciated.
 

·
Registered
Joined
·
3 Posts
i had same thing happen to my ml it was a sensor on the front wheel that needed replacing to do with the braking system
 

·
Registered
ml 320 1998
Joined
·
213 Posts
Discussion Starter · #9 ·
hi guys changed the battery still got the same lights lit up on the dash, took the vercle to a mate of mine who has got a machine the error codes are as follows.
c1200
brake light switch s9/1
c1141 b34 esp
pressure sensor fault.
c1140
steering angle sesor is not initialized c1025 Abs can bus signal cannot be transfered im thinking on getting a new brake switch, would i have to reset the codes again or would the lights go out themselves if the brake switch is the problem.
regards.
 

·
Outstanding Contributor
2006 ML500 2002 ML320
Joined
·
17,671 Posts
The cheapest way to go on this one is a $15 brake light switch. Replacing it has worked for many on this forum.
 
1 - 10 of 10 Posts
Top