Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
hi all,
i just bought my 1st Mercedes about 2 month ago. its a 2000 e320 4matic. great car with one major problem. the AC/heat got a mind of its own. sometimes when i put the heat on it works (the blower motor) and other times it wont work for a week then all the sudden, it comes back on.....
when i found out about this last month, i didn't really think it was a big deal until yesterday i almost got into an accident on the highway because the all the windows were so foggy and i couldn't see anything.
i don't know if the blower motor is bad or the regulator or something else is going on.

please let me know what to do because i don't want to be that situation again.

thank you
 

·
Registered
Joined
·
6,019 Posts
Run the climate control diagnostics and error codes

How to Diagnose Air Conditioning Malfunctions | EclassBenz.com
post the values 1-8 and the errors.
write them down for your forensic record keeping.
Then clear the error codes while in error mode by pressing both auto buttons at the same.
After you do that you can test the fuse and the wiring for the blower and even check the blower motor.Blower regulators are a known failure point.R/R article is in the diy section at the top of the forum.
keep us posted
:bowdown:
 

·
Registered
Joined
·
3,972 Posts
Welcome to the forum, Hamada. Please take a moment to complete your user profile ("User CP" link) with your location and vehicle model/year.

Do you have automatic climate control?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
ohlord,
thank you,i pulled the codes and here's what i got
(1-55) (2-51) (3-76) (4-82) (5-53) (6-164) (7-03) (8-46)
and the codes,
b1234, b1424, b1416.
now, what those codes mean and are they the reasone my heat keeps shutting off, where can i find the fuse for the blower.
thank you again.
 

·
Registered
Joined
·
3,972 Posts
ohlord,
thank you,i pulled the codes and here's what i got
(1-55) (2-51) (3-76) (4-82) (5-53) (6-164) (7-03) (8-46)
and the codes,
b1234, b1424, b1416.
now, what those codes mean and are they the reasone my heat keeps shutting off, where can i find the fuse for the blower.
thank you again.
The codes are here:

http://www.benzworld.org/forums/w210-e-class/1384396-automatic-climate-control-diagnostic-trouble-code.html#post2947104

b1234 is the sun sensor and always occurs. Ignore it.
b1416 is the electric coolant pump. That is really only needed for the REST feature, but I would ensure that the motor is not shorted.
B1424 is the activated charcoal filter door. This is probably not related to your problem, and I haven't seen anyone post of this before.

Your regulator is most likely bad. Check for 12V at the motor lead. If that is present, apply 12V across the motor (by disconnecting the regulator and grounding that motor lead).
 

·
Registered
Joined
·
7 Posts
Discussion Starter #7
i wired the blower motor and it worked, so i guess my only option is the regulator. any ideas where can i find cheap one.
i asked around and i the lowest i found was $285 AND i'm not sure if this is going to fix the problem.
thank you.
 

·
Registered
Joined
·
3,972 Posts
Disconnect the other side of the regulator (the small wires) and measure the voltage between them as you modulate the fan speed with the pushbutton unit. If you get a 0-6V signal at these wires, your problem is almost certainly limited to the regulator.

I have no idea of the best place to purchase this part. Ensure that your car is after the cutoff for the new-style system before you buy one.
 
1 - 8 of 8 Posts
Top