Mercedes-Benz Forum banner

NEED HELP FAST!!! BRAKE BLEED QUESTION!!

871 Views 0 Replies 1 Participant Last post by  threepoint1415926
Hey all! My car's been on jack stands for the better part of 3 days now because I can't get the brakes bled properly. It all started with replacing the brake pads on the front of the car. Just as I was lowering the driver side caliper, I heard a "ppssss" I broke the boot. To make a long story short, I replaced both boots and both piston seals for both front calipers. When I went to bleed the brakes, front ones bled fine. All the air was out and I was getting clear/new fluid through both front calipers. I moved on to the back and I got some old fluid out but then when my buddy kept pumping, fluid stopped coming out on both. Instead, nothing came out. It seems like some air is coming out but that's it. So I though maybe It just has a lot of air. Wrong! I hooked up the mightyvac and pumped for the better part of an hour hearing nothing but gargling sounds and no fluid. So I though maybe the bleed nipple on the caliper was leaking air through the thread. I put some Teflon tape on the thread and still, just gargling and no fluid. Both front ones worked fine and back are still non functional. I can easily press the pedal all the way to the floor now. I don't have ABS so there shouldn't be any special procedures. The brake light stays on when the car is running so I thought the PDWA was tripped. I still think this is the culprit but I can't seem to get it switched back.

PLEASE HELP!!!!!!!!!!!!! If you happen to know the answer, email me so I may get a qucik response [email protected]

Jon-Michael
Top