Mercedes-Benz Forum banner

1 - 20 of 21 Posts

·
Registered
2008 c350 2006 c230 sport six speed
Joined
·
8 Posts
Discussion Starter #1
i have a 06 c230 sport six speed with about 160k im throwing a p0300 which is a random cylinder misfire and a p0301 302 303 304 305 and 306 wich is a misfire on every cylinder also throwing a p2189 ssytem to lean at idle on bank 1 p2187 system too lean at idle bank 1 possible coils any help :crybaby2::crybaby2::crybaby2:
 

·
Registered
2008 c350 2006 c230 sport six speed
Joined
·
8 Posts
Discussion Starter #4
It could be cause I've changed the plugs already and the idle goes up to like 2 and then returns to normal you don't know of a good way to test it
 

·
Registered
Joined
·
18 Posts
I had the same problem. My check engine light came on, i ran codes and I got some of the same codes; random misfire and idle bank too lean. Is your car idling real rough and does your car shake when coming to a stop light? I took my car to an Indy and they replaced the MAF and the check engine light has not come back and the car idles normally now. The MAF is real easy to replace and will take less than 5 minutes to replace.
 

·
Registered
Joined
·
164 Posts
Would the 02 cause it to throw CEl for misfires
My understanding is that the computer takes the values from the oxygen sensors and uses these in determining the fuel-air mixture. So, if a sensor is bad, you could be getting a bad mixture which might cause your random misfire. Bill
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
MAF sensor or a very large air leak. 02 sensor failure would only affect one bank and not both. The other possible is bad fuel or low fuel pressure.
 

·
Registered
Joined
·
164 Posts
MAF sensor or a very large air leak. 02 sensor failure would only affect one bank and not both. The other possible is bad fuel or low fuel pressure.
That this is a V-6 instead of the earlier four went right over my head! You are right about a bad oxygen sensor in this engine would only affect one bank. Bill
 

·
Registered
2008 c350 2006 c230 sport six speed
Joined
·
8 Posts
Discussion Starter #10
I had the same problem. My check engine light came on, i ran codes and I got some of the same codes; random misfire and idle bank too lean. Is your car idling real rough and does your car shake when coming to a stop light? I took my car to an Indy and they replaced the MAF and the check engine light has not come back and the car idles normally now. The MAF is real easy to replace and will take less than 5 minutes to replace.
Ima try the maf cause I don't think all six coils can be bad and yeah car shakes alot at idle and idle goes up And down is their any way to check the maf:confused::confused:
 

·
Registered
Joined
·
1,054 Posts
if the shaking at idle happens right away from a cold start then it is probably not the 02 sensor. the car runs without input from the 02 sensor for the first few minutes (until it warms up).

Ima try the maf cause I don't think all six coils can be bad and yeah car shakes alot at idle and idle goes up And down is their any way to check the maf:confused::confused:
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Ima try the maf cause I don't think all six coils can be bad and yeah car shakes alot at idle and idle goes up And down is their any way to check the maf:confused::confused:
You can only check the MAF with Benz diagnostic equipment ie Star. But if the engine rpm is going up and down it points towards a large vacuum leak.
 

·
Registered
2008 c350 2006 c230 sport six speed
Joined
·
8 Posts
Discussion Starter #13
You can only check the MAF with Benz diagnostic equipment ie Star. But if the engine rpm is going up and down it points towards a large vacuum leak.
Right in front of the engine a little left to the oil filter I've sprayed carb cleaner in their and idle instantly goes up but I don't see any broke lines ima have to take it apart and check and that will also cause the misfire
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
Right in front of the engine a little left to the oil filter I've sprayed carb cleaner in their and idle instantly goes up but I don't see any broke lines ima have to take it apart and check and that will also cause the misfire
You most certainly have a leak, inspect it further.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,344 Posts
I believe the PCV is there to the left of the oil filter. It has a vacuum hose that could leak, or the EGR valve itself could be stuck open. Eric has you on the tight track.
 

·
Registered
2008 c350 2006 c230 sport six speed
Joined
·
8 Posts
Discussion Starter #17
So I unplugged my maf and car runs exactly the same so is it the maf I really appreciate the help everyone
 

·
Outstanding Contributor - Always Remembered, RIP
Zotye Auto 1.5T T600 2016
Joined
·
52,804 Posts
So I unplugged my maf and car runs exactly the same so is it the maf I really appreciate the help everyone
This does not tell us anything, the MAF can only be checked using live data on SDS.
 

·
Registered
Joined
·
2 Posts
  1. Ok so dunno if this is even close to problems ur having but I bought my 06 v6 c230 and drove great first two days and then I parked it one night and next day on startup really bad miss and i live with my ex wife...smh don't ask but accused her f boy of doing sumpin to my car and she said stfu and shook her head but I was like wtf and began pulling coil pack plugs to find where miss was from and found passengers. Side front two banks not hitting at all so pulled plugs and gaps on these two cylinders where touching.....wtf!!!!..... So replaced all 6 plugs and ran good for bout 30 miles and then again same shit different plugs so regapped and reinstalled watched hrs of utube vids and notta....but heres what I have decided after putting up hidden trail cams lotsa headscratching and fucking lotta german wtf was they thinking cause i couldnt catch ol boy at his sabatoge n da Benz...lol....ok so lott more thinkin and one more slip up showed me that I had accidently put 87 octane gas into my car not one twice but 3 times and thats where all my bullshit closed gaps started on new plugs still dunno how or why but yes I urge all of ya to pull plugs with a bad miss and check the gaps closely and have read about disssentegrated plastic from intake but find it really hard to believe that not once twice but 3 times I sucked plastic thru my v6 obviously very close piston to valve clearances and never bent a valve and have no bearing knock and after regapping and lil 93octane runs like scolded dog....well like a dog happy ur home.....lol...but yes im gonna doulble up my spark plug washers next and try the 87 again and see if this happens again but I am saying i can change parts understand air fire n fuel is neccesities to a running engine but how does low octane fuel put enough carbon on top of pistons to hit the spark plug gaps together and am trying to find sum info on governor delete or programmers to raise the 130 mph cutoff cause that is where my lil v6 shines is on the top end and sure it is capable of its 160 Mark she was born with....any help would b appreciated and hope this helps summa y'all....also dyno mode on this car is fun with the autostick adapted to ur right foot on damp roads but b modest when she comes around its fast and in a hurry but fun to walk thru so far first 3 gears depending on roadsurface.....####drive it like u stole it###
 

·
Registered
2002 Mercedes Benz C320 Wagon
Joined
·
73 Posts
Sounds like a vacuum leak. The back of the engine where the MaF sensor is has a few small vacuum hoses that could be brittle and have hairline cracks. Your car will run but run horrible. I’ve bought vacuum hoses at all the auto parts stores for close to $1 per foot. It’s not a bad investment to spend under $10 and buy new. They are super simple to replace and your car will thank you.
I love my 2002 C320 wagon. I think these cars are super easy for diy-ers to fix at home.
 
1 - 20 of 21 Posts
Top