Mercedes-Benz Forum banner
1 - 4 of 4 Posts

· Registered
1995 E420
Joined
·
3 Posts
Discussion Starter · #1 ·
I searched the forums and found references to some nice documentation sold by "kestas" but can't actually find how to buy them. Is he still around?

My 1995 E420 with 104K intermittently loses many interior control functions (power windows, sunroof, windshield wiper/spritzer and seats) all at the same time. I am hoping for a bad connector somewhere, as I expect a wiring harness replacement in that area is very difficult.

Anyway, I can't seem to find decent technical documentation on the car. The eBay cheapo knockoff CD completely baffles me when I try to find anything.

Anyway, if Kestas is still out there, or someone knows the most obvious place to start looking for good electrical system documentation I would appreciate any help you could offer.

Craig
 

· Registered
95 E320 Cabriolet, 140K
Joined
·
1,337 Posts
I believe the CD I provide is the same thing as the one offered on eBay, so I can't help any further in that regard. Just so were on the same page, my CD is the W124 Service CD, not the one that covers 1971 to 2005, or some other overly-general disc.

I agree the electrical part of the manual is hard to navigate. The CD gives you the electrical diagram, but the hard part comes when you are trying to match the diagram with the actual vehicle.

There are other parts of the manual that point to the location of the electrical components. They mark the components using MB lingo, like K47 and N12. Often these diagrams are hard to match the car also, but you have to try.

Your problem may very well be from brittle wiring insulation. The engine wiring harness has been thoroughly discussed, but I've had problems with "stiff" wiring elsewhere on the vehicle that doesn't want to flex.
 

· Registered
2006 S500 AMG Wifes Rig Hillbilly Girl 02 ML320
Joined
·
2,350 Posts
Ya might want to DOUBLE check your fuses!! Really weird things happen when you lose one! Look for hairline breaks in the element!![:(!][:(!]

Smokie
 

· Registered
1995 E420
Joined
·
3 Posts
Discussion Starter · #4 ·
I will go and double check the fuses. I have to admit that since it is intermittent I dismissed the fuses as a source. My greatest fear is cracked insulation somewhere. I bet replacing the interior wiring harness is not a pleasnt afternoon job...

Thanks.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top