Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello Forum experts

I need some advice regarding a situation with my 2003 c209 coupe with the m112.955 engine. I have 128k miles on the engine and recently picked up a spare engine on ebay with 74k miles for cheap.

1. I am getting severe valve rattle noise from the right side head, and my mechanic broke one of the bolts off, so now 13-14 are tightened and torqued to spec

I took the valve cover off and noticed some side to side play on the Rocker arm assembly or camshaft bearing bridge. Is that an issue?

Note the new engine rocker arm assenbly also has side to side play

See videos
<<<< Valve ticking

<<<Rocker arm side to side play


So here is my question;
do i selll both car and new engine and cut losses?
do i swap entire engine and possible risk the new engine being bad
do i just take the camshaft bearing bridge of the new engine and try it on the old? <<< I can do this job and is the cheapest solution
do i attempt to get a refurbished cylnder head?

Please help guide with any advise so i dont waste my time or money.
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Here is a picture of the rocket arm assembly AKA camshaft bearing bridge

Here is a picture of the rocket arm assembly AKA camshaft bearing bridge notice number 10 bolt is missing
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Problem Solved!!!!

I took the cam bearing shaft from the new motor, took of existing CAM bearing shaft, removed broken bolt. Tightened down to spec, and the valves are perfect!!!
 

·
Coupe/Convertible Forums Moderator
Joined
·
18,857 Posts
Yeah, there's a reason that bolt it there - they generally don't build engines with spare head bolts :) Glad you sorted it out.
 

·
Registered
Joined
·
13 Posts
After a lenghty search on same issue. Here's what i found. I was told this would fix it and it did for this guys car. The guy said

"The ticking is because the cam oiler tubes have a plastic end cap that blows off, crappy design. Replace it with the aluminum one piece design with the allen wrench end cap. Rauch & Spiegel part # 119-180-02-66-M157 "
 

·
Registered
Joined
·
162 Posts
I took the cam bearing shaft from the new motor, took of existing CAM bearing shaft, removed broken bolt. Tightened down to spec, and the valves are perfect!!!
I have a valve rattle noise as well in my 2005 CLK 320 M112 engine, but it's much slower than yours. It's been going on for a year or so and my mechanic said that I shouldn't worry about it since I don't plan on keeping the car for more than 1-2 years.

You can check out the noise here: https://www.dropbox.com/s/z51ia7g04w9ngbi/M112 Knocking Sound.mp3?dl=0

The noise comes on when the oil is hot and the car is in D or R with the brakes applied.

After reading your thread, I got thinking whether it's the same problem and solution.

Could you please hear it out and let me know what you think?
 

·
Registered
Joined
·
125 Posts
I have a valve rattle noise as well in my 2005 CLK 320 M112 engine, but it's much slower than yours. It's been going on for a year or so and my mechanic said that I shouldn't worry about it since I don't plan on keeping the car for more than 1-2 years.

You can check out the noise here: https://www.dropbox.com/s/z51ia7g04w9ngbi/M112 Knocking Sound.mp3?dl=0

The noise comes on when the oil is hot and the car is in D or R with the brakes applied.

After reading your thread, I got thinking whether it's the same problem and solution.

Could you please hear it out and let me know what you think?
Whoa, this sounds EXACTLY like my 2001 w/210. Did you find out any more info?

BTW, not sure if people bothered to download your file from dropbox. I copied it to Google Drive so it could be played from that link without a download. That's here: https://drive.google.com/open?id=0B4aT_tPovn5ASDFhWWxmeG4zdXc

If you want me to take it down just let me know. My thread on this issue is over in the w210 section: http://www.benzworld.org/forums/w210-e-class/2865906-tocktocktocktock-not-good-sound-i-think.html
 

·
Registered
Joined
·
162 Posts
Whoa, this sounds EXACTLY like my 2001 w/210. Did you find out any more info?

BTW, not sure if people bothered to download your file from dropbox. I copied it to Google Drive so it could be played from that link without a download. That's here: https://drive.google.com/open?id=0B4aT_tPovn5ASDFhWWxmeG4zdXc

If you want me to take it down just let me know. My thread on this issue is over in the w210 section: http://www.benzworld.org/forums/w210-e-class/2865906-tocktocktocktock-not-good-sound-i-think.html
Hello!

Finally someone with the same problem! No, I still haven't gotten any info, but please check my two other threads for info and development and chime in there.

https://mbworld.org/forums/clk-class-w209/634231-m112-engine-knocking-sound.html

http://www.benzworld.org/forums/c209-a209-clk-class/2865362-m112-high-rpm-wobble-noise.html

No problem with the Google Drive posting. Thanks a lot in fact. I'll update my links to reflect that given that you'll keep it online.

Thanks.
 

·
Registered
Joined
·
257 Posts
Was the #10 bolt the one your mechanic broke??? Also was it making the tapping sound before your mechanic broken the #10 bolt??? Or was it making the tapping sound before and after the bolt was borken???
 

·
Registered
Joined
·
162 Posts
So after using a mechanic's stethoscope, the lifter/tock tock sound is coming from here:




Any suggestions as what to do next? Just remove the valve covers and start changing parts?
 
1 - 12 of 12 Posts
Top