Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,Yesterday i went to the local delta sonic,Before entering the wash everything was working properly.After wash i went to pull out of the parking lot and i noticed that the car would not shift out of 2nd,I would have all the power of second gear all the way to redline but woul not shift.When i came to a stoplight i shifted the car in park,the tried manually shifting thruthe gears but it seems as though its always in 2nd gear.This is the kicker,apon arriving home i pulled in my garage and just so happen to try reverse and guess what?It still was in gear and the same thin with neutral ,it was still in gear. Can anyone please help.Thank you
 

·
Registered
1998 Mercedes-Benz S500
Joined
·
929 Posts
First: If your car is 1996 and up then check the cable that goes from the Transmission to the control unit.
Second: check your Transmission Control Unit,you may have water or oil in.
Third: check the drain hole on passenger side.
Good Luck!!!
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,663 Posts
maybe the selector switch is wet.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,663 Posts
if you feel the linkage moving then its your gear selector switch its stuck,
 

·
Registered
nothing broken. finally!
Joined
·
2,619 Posts
maximos has it

P R N D

are 100000% mechanical engagement.

gear selector switch has nothing to do with shifting the mechanical points of the box, neither does the tcu

if you put it in P and it's still in gear, your linkage clip at the shift arm probably fell and the rod slid off

if your shifter got lose and you moved the lever then it will mismatch between what it reads and what the box is in putting you in limp. makes sense?
 
1 - 7 of 7 Posts
Top