Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
hey. when i pull my hood release cable on my 89 300 se, only the passenger side pops up. i have no idea how to pop it up. i tried popping it like 20 times always with the same results. does anyone know how to fix this problem and help me get my hood up? if so please tell meand your knowledge will be greatly appreciated.i cant really drive it like this cause it leaks oil and i dont want to be driving it with low oil and i cant check it or fill it with out opening the hood
 

·
CH4S Admin , Outstanding Contributor
Joined
·
39,267 Posts
Have you tried a forum search (3 words)?
Welcome. To re visit the 'Welcome to the Forum' tutorial sticky on top of the page, will show you how to complete a profile, search the forum, and has the link to the Russian MB site with an exploded parts view, and to run a VIN #.

Have you tried to have someone push/pull the hood, while you pull the release?
The pdf should help
 

Attachments

·
Registered
Joined
·
212 Posts
hmm, i'm just taking a shot in the dark here, hell, what is there to lose?

Have you tried pushing down the passenger side with some pressure? If so try that and then have someone hold down the driver's side while you pull the latch. I hope it works, It would help me if it were to ever happen too me as well.

Also, Is there anyway to take out the release cable and see if there's anything wrong there? (don't try this without confirmation from someone else other than me, for my peace of mind).
 

·
Registered
Joined
·
1,648 Posts
Years ago mine did something similar. On a real cold day I would pull the handle and the drivers side would take a little longer than the passenger side to "pop". The catch needed a thorough cleaning and lube. I would try pulling the handle while someone else jiggled the hood. If that does not work I would wait for a much warmer day. BTW the cable can be adjusted.
 

·
Registered
Joined
·
617 Posts
You can also go to sears and get one of their steel 'picks' with a hook on the end. Its about six-eight inches long...Griot's garage has them too if you want to see what I'm talking about....(or any good auto parts store). You can get under the car, guide the "pick" through the grill, hook it onto the release latch and pull. You might be able to pull it out further than the cable will pull on the release latch.

Don't ask how I learned this trick...did something ultimately stupid one day.


.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
what did the steel pick look like? cause im gonna have to go to sears and get one. i have a pretty small one and i couldnt get it through the holes on the grill
 

·
Registered
Joined
·
166 Posts
Re: Problem with the hood...

hey. when i pull my hood release cable on my 89 300 se, only the passenger side pops up. i have no idea how to pop it up. i tried popping it like 20 times always with the same results. does anyone know how to fix this problem and help me get my hood up? if so please tell meand your knowledge will be greatly appreciated.i cant really drive it like this cause it leaks oil and i dont want to be driving it with low oil and i cant check it or fill it with out opening the hood
*************************************************************

Hello!
I have gotten the same car and when you will pull the metal part, located on the left side, beside the hand brake, you should hear the popping sound and then in front of your grill (a little bit to the left, should come out the plastic part, which you will need to pull & at the same time to bring up the hood). If it won't help - get the WD40 or liquid wrench and spray with the tube up to the side, which won't open... when you will open the hood, lubricate well the let front and right locks - to let it open... try also to lightly press on the front of the hood about 10-15 times, then pull the plastic part and try to open the hood... Let me know.
Racing1219.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #8
i tried pretty much everything you said racing1219 with no luck.thanks for the advise tho. i dont think the cable is attached to the first latch properly. i just got back from sears after buying a little pick set. and i am going to try yo open it manually by pulling on it with the pick. hopefully i can figure out where to pull it from.
 
1 - 9 of 9 Posts
Top