Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
Hi fellow E55 owners! I'm new to the group, on Friday of last week I purchased my first AMG. Its a 2002 with 44,800 miles. On Sat I had my first problem...

In the week before I purchase the E55 it received all the maintenance my indy shop suggested. The Seller had all the work done at the MB dealer on his dime. ($3,486) As part of the work the car recieved new motor mounts and a new Crank Position Sensor. The car had a new Mass Airflow Sensor installed about 5 months ago. I was driving the car over the weekend and pushed on the gas heavy, the car hesitated and the CE light came on then it accelerated. The car continued to run OK and I drove it home. :cool: The OBDII scanner said Misfire on Cyl 6. Since the MAF and CPS have been replaced what should be my next step in troubleshooting? (I have not checked the Air Filters but I ordered a set anyway and should receive them Friday)

Another bit of info which may help (or it might be normal?) the E55 engine turns over 5-7 times before starting when cold where my CLK430 v8 only turns over 3-4 times before starting. When idle the E55 seems to idle a little rough, not like a misfire but more like a spark plug is firing a couple milliseconds off.

Thanks!
 

·
Registered
Joined
·
10 Posts
Reply

Definitely want to get it checked out at the MB Dealer. I would check you Spark Plug wires, however, at 44K they should be fine, but you never know. My E55 use to hesitate at first take off however, I replaced the MAF Sensor, Spark Plugs, Spark Plug Wires and Fuel Filter! All I can say is WOW what a difference. Surprised a C63 yesterday. I was on his bumper like a Pit Bull on a Chihuahua. :thumbsup: However, the guy had 30 day tags so i knew he had just bought the car. But the maintenance done completely brought the car to life. Oh yeah, I also did the ECU Reset as well. As a side not make sure that you don't hit the "W" button near your transmission as your car will drive different while in Winter Mode. I have did this on several occasions especially while cleaning the interior. But the performance after the maintenance was incredible. Once the C63 pulled up to me at the light, he looked as though someone had a gun to his head. As a matter of fact this is the look he had on his face....:eek:
 

·
Registered
2004 Mercedes-Benz S55 ///AMG, 2006 Mercedes-Benz E350
Joined
·
685 Posts
Speaking of Mass Airflow Sensor, where is this unit located? I am assuming after the air filter in the plastic tube/housing, correct?

Is it a goos idea to clean the AMF sensor with a proper cleaner every few months or so?
 

·
Registered
1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Joined
·
7,035 Posts
My comments

Yes - on the MAF, the airfilter housing comes off, and the MAF is located in the throat leading to the intake. comes off easiliy, but in older W210's the fastening plastic collar sometimes gets brittle (from the extended heat) and needs to be replaced to hold the MAF securely. Behind the MAF there are some driecting air flow vents in the throat, some hard core's claim Dremeling those increase mid-range, I think they are wild minded.

I would not clean the MAF, the airbox gobbles a lot of air, but the correct air filters are effective. K&N's can frack up the MAF easy, Replace it for less than $200 and let it rest in peace for another 100K+ miles

On the OP, a 2002 with "failed" motor mounts seems very unusual to me.

To the OP, do a soft reboot of the system (do a forum search) to reset the ECU and the tranny - THEN go out and do a full throttle test on the open road.
 
1 - 7 of 7 Posts
Top