Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
yes i became crazy of this problem and i need the experts here cos I don't know what else to do . i have a 500 sl 1991 very clean and not being used for more than 75000 km , every thing is clean like a brand new car , its not being used for long time and parked in store . the problem am having is when the car is on -started- the engine is missing and shaking , not stable at all , i did everything you expect , changed the engine oil , i put new plugs , new injectors , new air filter , changed the head of the injector box , cleaned everything ,i put a special liquid for cleaning the fuel system and took the car for a long drive in high speed 180 , changed the fuel tank filter , i changed the engine mounting all of them , but still the car is missing and engine is shaking and also when i drive in a curve or turning the car ,it makes me feel that there is no fuel in the car and disconnects from the engine power and when the car is straight it will become normal , i am really getting crazy and now getting to hate the car ,any one sets in the car will feel the missing , i am having 2 500 sl same model but only this one is making me tired . please i need help .:crybaby2:
 

·
Registered
00 SL500 SOLD, 05 SL600 Sport, 09 Silverado 4x4 LTZ,SOLD '15Silverado LTZ 6.2 8Speed John Deere 318
Joined
·
1,781 Posts
Have you changed the PLUG WIRES? Have you had the Ignition distributor caps checked? Ignition COIL??? Other than these items, I'm not sure, SORRY!!!!!!
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,391 Posts
yes i became crazy of this problem and i need the experts here cos I don't know what else to do . i have a 500 sl 1991 very clean and not being used for more than 75000 km , every thing is clean like a brand new car , its not being used for long time and parked in store . the problem am having is when the car is on -started- the engine is missing and shaking , not stable at all , i did everything you expect , changed the engine oil , i put new plugs , new injectors , new air filter , changed the head of the injector box , cleaned everything ,i put a special liquid for cleaning the fuel system and took the car for a long drive in high speed 180 , changed the fuel tank filter , i changed the engine mounting all of them , but still the car is missing and engine is shaking and also when i drive in a curve or turning the car ,it makes me feel that there is no fuel in the car and disconnects from the engine power and when the car is straight it will become normal , i am really getting crazy and now getting to hate the car ,any one sets in the car will feel the missing , i am having 2 500 sl same model but only this one is making me tired . please i need help .:crybaby2:


I understand your frustration.
The description you give shaking on curves, tells me that you have more of the problem
number one.
1. Check the 02 sensor WIRES shorting on the drive shaft, if they did you may have to replace some more parts, module etc.
Or if you are lucky tape them. ;)

2. Open the distributor caps ck for arks, ck rotors, especially the rotor adapters the have been upgraded you must install the new type.
Do that and come back.

Regards.
aam.
 

·
Registered
1991 R129 500SL
Joined
·
1,822 Posts
I understand your frustration.
The description you give shaking on curves, tells me that you have more of the problem
number one.
1. Check the 02 sensor WIRES shorting on the drive shaft, if they did you may have to replace some more parts, module etc.
Or if you are lucky tape them. ;)

2. Open the distributor caps ck for arks, ck rotors, especially the rotor adapters the have been upgraded you must install the new type.
Do that and come back.

Regards.
aam.
Hi aam,
You mentioned about the rotor adapters being upgraded, would you have the part numbers for these?
Thank you in advance. :)
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,391 Posts
Hi aam,
You mentioned about the rotor adapters being upgraded, would you have the part numbers for these?
Thank you in advance. :)

There you go my friends.
Rotor adapter or bracket it is the same thing.

Old number,# 1191580440 no good any more.

If you don't replace them you will brake the new rotor in no time, also there is a fire danger.
And obvious the engine is not going to run well.
Don't forget these things spin very fast and high electric current runs through them..
When I bought my car after a while I had this kind of problems.
So I found out that both rotors where new and cracked.
So I wend hunting, spark plugs, etc.

New part #1191580640
Bosch #1230328037
autohausaz has them.

Regards.
aam.
 
1 - 6 of 6 Posts
Top