Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
C200 KOMP. Coupe
Joined
·
34 Posts
Discussion Starter #1
Okay, it’s a 2002 Mercedes C200 kompressor.

I have my car since last April. And funny thing the time of its first service just arrived and I took it the service today.

anyway my problem is… I noticed for a while now that my car doesn’t accelerate as it used to before.
I didn’t have any prove and I though I’m wrong. Till few days ago. I raced two cars twice. They were just like mine… and they all were faster than me and passed me. They were soooo far away from me in few seconds!!!! Like if they were driving a 6 cylinders car or something! But no, they were driving C200 kompressor.

Heh, its funny but here people with same cars like to race, there cars usually drive on the same line right next to each others all the time.

But with me… I failed… two C200 kompressor cars were faster in acceleration than me. NO they were not modified or anything…

what do you think the problem is?
I got ripped off at the garage today because of this problem! They connected that laptop to my car and they didn’t find any problem. They took it in a ride and they said there seems nothing wrong BUT they recommended that I do “a fuel system cleaning�. I don’t know what does that means, but that’s what they said. It costs about 300 bucks without the parts (the parts cost me 100 bucks).
I was so dispirit especially that I was racing girls and they made me look stupid so I said okay.
The garage also said I should change the air filter and sparks. (I have only 11000 miles on it by the way).
So? What do you think?

Thanks guys for ur time.
 

·
Registered
C200 KOMP. Coupe
Joined
·
34 Posts
Discussion Starter #3
nah, they don't have anything. they were just normal girls one of them was going to the ...

nah, they don't have anything. they were just normal girls one of them was going to the mall and the other just left her house! so I really doubt any of them made any modifications on their cars.
 
1 - 3 of 3 Posts
Top