Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi

I need and advise or recommendation about where to start to fix my car, Im pretty handy and do regular maintenance to my car and I hope this can be something I can fix at my garage. My car is a C230 2003 1.8+ kompressor engine.

My car had a problem 4 months ago with the transmission which was replaced
at that time the mechanic didn't have the tool to clear the codes and it takes like 1 month to make it done. After that I just drive it once to make sure that it shifts properly and it car was running good but I didn't use more because I wanted to replace the alternator which was making some kind of metal to metal noise from long time ago, so I let it wait for ~1 month more until I replace the alternator for a new one but Now the car doesn't want to run just crank several times :eek:

Seems like no fuel but really I don't know what I check firstly to approach to cause:confused:.
Might be an issue cause during the new alternator replacement? something related that might be close that bay disconnected or broken by accident?

I'll appreciate any guidance list about what and where and how to check

best regards and thanks alot for your help
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,463 Posts
A common problem is a bad CPS, but those usually fail due to heat, as in not starting after the car has been driven on a hot day. It could be a fuel delivery problem - check the pressure (CAREFULLY!) at the Schrader valve on the fuel line on top of the engine.
 
1 - 3 of 3 Posts
Top