Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
C220 , 1994
Joined
·
63 Posts
Discussion Starter #1
I bought my C 220 113000 miles on it before a month .. Now it cannot start up when I drive for few miles in city and then turn the keys off. It happens occasionally but now the frequence of this problem has increased.. I have to wait for 2-3 hours before it can again start up. My Engine coolant temperature guage is not working on the dashboard.. I went to independent mechanic today and he told me that the fan which cools engine is not working properly and the some clutch belt which runs this fan aslo need the replacement.. He gave me an estimate of 450 $ for all this repair.. Can anyone tell me if this can be the problem or anything else? The temperature guage is 1200 $ and I cannot afford that.SO decided to replace the fan and belt only. When i rotate the key it rotates the belt but engine doesnt get started.
 

·
Registered
1996 Mercedes C220, 100K as of 4/07
Joined
·
30 Posts
1. You better get some kind of temp gauge. Are you saying that the temp sender unit is $1,200 US? That cannot be right. I suggest looking at some online parts stores. Worst case you get an aftermarket temp sender and gauge and mount it under your dash. But you HAVE to know if it's about to overheat.

2. Your problem with the starting sounds like the fuel is vaporizing in the fuel rail due to heat. You say that the car is inoperable for 2 hrs after reaching operating temp (whatever that is, as we have no gauge). Have you tried opening the hood to let it cool faster?

You could also pour a bucket of icewater on the engine (no, I'm kidding, don't do this!).
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
Your cranking problem is your OVP relay. If the old part is 000-540-52-45 then replace with new part 000-540-67-45. Do a search as it has been discussed plenty before.




The needles on these models stick, and is not an indicator of any cooling parts not working. You can either pull the cluster and clean the needles with alcohol or put little sleeves on them so they won't stick. Another method, is patting the top of the dash and a few times.
 

·
Registered
C220 , 1994
Joined
·
63 Posts
Discussion Starter #4
Thanks, but car now dont gets sarted even without running a mile...it is idle for las t 2 days and now not getting started.......i am so tired of these problems.....i checked with a mechanic and he told me that some fan which thrws engine heat out from the front part is not working properly and the clutch attached to that fan is also malfunctioned so need to change that---- he gave me an stimate of 500 $ for those 2 parts change...but if it s the temperature probel --why the car is not getting turn on even it didnt run any mile.......should i go to dealer? you told me to check that part which you described above but how to locate this part?
 

·
Registered
'99 2.3L Kompressor
Joined
·
1,944 Posts
If the OVP checks out and isn't the problem and if your car has the crank position sensor, the CPS is the next place I would look given the symptoms you described.
 

·
Registered
C220 , 1994
Joined
·
63 Posts
Discussion Starter #6
ok but can i ask u a question? when i try to start a car--- it rotates the ignition and also the battery powered motor--the only thing is engine can not get started .....DO U STILL THINK IT IS THE OVP? BECAUSE I HINK MY BATTERY PROVIDES ENOUGH POWER TO START THE ENGINE....CAN OVP BE INVOLVED IF BATTERY IS ROATATING THE MOTOR BUT ENGINE CAN NOT BE STARTED?
 
1 - 6 of 6 Posts
Top