Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
SLK 320
Joined
·
41 Posts
Discussion Starter · #1 · (Edited)
I bought it 2 weeks ago so its still in the original condition. I only changed the audio system, because it was too bad. So here are some pictures for You
 

Attachments

·
Registered
SLK 320
Joined
·
41 Posts
Discussion Starter · #2 ·
it is 2002, 320 V6 model and now I plan 18" wheels /asa AR3 or OZ classe/ little bit lowering, the roof module to open and close it by the original key, "glass" windshot and the chrome pieces behind my head :)
 

·
Registered
2001 SLK320, 2001 C320
Joined
·
2,267 Posts
Sweet! A question (or two) about those speakers...

What size are they? Did you need to do any modifications to install them? I find the door speakers to be the worst part of the stereo system...by far!
 

·
Registered
2001 SLK320, 2001 C320
Joined
·
2,267 Posts
Very nice work! Do you have any photos showing the original speakers? What size were they?
 

·
Registered
2001 SLK320, 2001 C320
Joined
·
2,267 Posts
No wonder it sounds so bad. That speaker is horrible!
 

·
Registered
98 Slk230
Joined
·
231 Posts
It looks like you have some rust on the bar inside the door...

The black plastic cover protects the speaker magnet from moisture and corrosion but since you're not reusing it, how are you protecting the new speakers?

Also, I am not sure but it looks like you put the crossovers on the outside of the inner door skin - is that right? I am just curious cause it'll have moisture issues too.
 

·
Registered
SLK 320
Joined
·
41 Posts
Discussion Starter · #10 ·
I don ´t protect it, You are right the crossovers are also there and not protected. I duse the car only when the sun shines :)
 

·
Registered
98 Slk230
Joined
·
231 Posts
What about the rear speakers?..

Looks like you're still using the Bose woofers in the rear - right? Where did you put the new amp and most importantly - how does it sound over the original setup?
 

·
Registered
SLK 320
Joined
·
41 Posts
Discussion Starter · #12 ·
the amp is not yet installed. It will be under the legs of my girlfriend :) where the original amp is installed when bose system is there. My car was only Audio 30 without any woofers and I will not install any SW. And finally now it plays only with the amp from HU and it sounds very well, only there is not enough power for the speakers, thats we I bought the amp. We will install the amp some day next week, so I can post some pictures again
 

·
Registered
98 Slk230
Joined
·
231 Posts
If the sound is that good, then you must've already

installed the tweeters - correct? How did you mount them - in the original housing or did you mod the door panels to fit them. More pics would be great.

When you install the amp, look in the upper right corner of the kickpanel, there's a rubber plug there that'll allow you to run your power cable thru the firewall and to the battery. I believe there's about 5 circular "flaps", the largest I think will accommodate a 4 AWG cable if you decide to go that large. 8 AWG is fine in your case however.
 

·
Registered
SLK 320
Joined
·
41 Posts
Discussion Starter · #14 ·
I have no picture with the tweeters and yes it´s in the original position. My firend with is a professional in car hifi business so he installed it and he will install the amp. so hopefully he knows :)
 

·
Registered
SLK..lower than yours
Joined
·
1,567 Posts
im assuming you had the standard stereo system? My car has the bose premium and to me, it sounds very nice...not the loudest, but nice bass..etc. Several members have upgraded there head units remaining with the stock bose-premium and they say it only gets better!!
 
1 - 16 of 16 Posts
Top