Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
99 ML430 (Gone) 2000 ML320
Joined
·
45 Posts
Discussion Starter #1
So I just picked up a "project" 2000 ML320. I have been working on my daughter's 99 ML430 for years and thought it would be "fun". My first question is on the Radio. The car had no radio in it when I got it. I picked up a "alpine" Mercedes unit from a 2001 ML320. Upon trying to install it I noticed my 2000 did not have the fiber optic connector. I plugged in the large connector plug, small connector plug and antenna. When I powered it up it went to "tele aid muted" so I was unable to enter unlock code. I messed with it for a while and was able to put car in reverse making the "tele aid muted" screen go away and the unlock screen came on. I entered my unlock code (which worked) but could not get any sound out of system. I pulled stereo and realized there was no fiber optic connector behind stereo. I took pictures of the wires hoping someone could identify them. So, in the first pic, the wires to the left, 2 plugs and antenna wire is what I connected. Any idea what all the other wires are for? How can I get sound out? And if the 2001 stereo will work in the 2000? The build sheet for mine and the donor car both list the "Alpine" stereo as the build spec. And what is the "blue" wire in pic 2? Also, thoughts on the "tele aid muted" screen Thank you in advance for the assistance. This forum was a lifesaver for my daughter's car.....?
 

Attachments

1 - 3 of 3 Posts
Top