Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
ml320
Joined
·
8 Posts
Discussion Starter · #1 ·
Your text here Hello, I was wondering if someone could help me out with my problem? My car is running sluggish and when it heats up it shuts off and wont start till its cooled down. I changes the oxygen sensors out and still the same problem. I was wondering if its the fuel filter, that could be clogged or is it the air handler. Please help me, im illiterate when it comes to mechanics. thank you
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
Possibility is that the fuel pump is binding when it get's hot. This was common with fuel pumps on pre-2002 ML's..

AC
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550 FORMER: C300, ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
22,890 Posts
Not starting when hot is also a symptom of CPS failure.
 

·
Registered
2014 RX 350 F Sport, 2007 Scion tC, 2000 ML 430 Money Pit Finally Gone! Oh Happy Day!
Joined
·
1,284 Posts
frankieluvv - 4/2/2006 3:46 PM

Your text here Hello, I was wondering if someone could help me out with my problem? My car is running sluggish and when it heats up it shuts off and wont start till its cooled down. I changes the oxygen sensors out and still the same problem. I was wondering if its the fuel filter, that could be clogged or is it the air handler. Please help me, im illiterate when it comes to mechanics. thank you
CPS (Crank Position Sensor)........... mine went out last week. Does not leave a code. $239.36 labor and materials at the dealer. Hope it runs long enough to get to the shop. Mercedes Roadside can't save you on this problem, except maybe give you a ride home. [;)]
 
1 - 5 of 5 Posts
Top