Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
ml270
Joined
·
11 Posts
Discussion Starter #1
hot starting ml270
hi all,
Ihave had numerous problems with starting when engine is warm or hot . MB HAVE HAD THE CAR ON 4 OCCASIONS !!this has resulted in new immobalizer unit and transponder, 2 new injectors fuel line and valves plus more recently new air mass flow that was for another reason . Today car started from cold and then when hot wouldnt . The recovery man sprayed easy start spray in inlet, and it started . he stated it could be cps sensor or another injector ? Could anyone share their knowledge with me please . Many thanks.once engine cools it starts again!
javascript:emoticon('flame')
flame

_________________
all help considered
View user's profile
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
Tony,

Please scan the truck for OBDII codes during the 'no start when hot' episodes.

If you come up with the code P0335, change your Crankshaft Position Sensor and you're good to go.
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,187 Posts
When starting fluid starts a vehicle it is a fuel delivery problem. Check fuel pressure with a gauge when the event occurs; fuel filter or fuel pump.
 

·
Registered
ML 270CDI 2002, BMW K1300S, VW POLO 1.9TDI
Joined
·
515 Posts
many thanks car booked into merc next
week will let you all know thanks
The cps is a strong favourite for causing this kind of problem and it doesnt always throw up a fault code.
 
1 - 7 of 7 Posts
Top