Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
ML W164 2009
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello all,

I have a problem with the electric tailgate on my 2009 ML 320 cdi. W164 It opens fine but when shutting with either the tailgate button or keyfob often the tailgate goes down a few inches and then goes back up.

Any help with this issue would be appreciated

Thanks........Shaun.
 

·
Registered
Dallas, Texas
Joined
·
12,026 Posts
Hello all,

I have a problem with the electric tailgate on my 2009 ML 320 cdi. W164 It opens fine but when shutting with either the tailgate button or keyfob often the tailgate goes down a few inches and then goes back up.

Any help with this issue would be appreciated

Thanks........Shaun.
Most likely faulty anti pinch sensor.

 

·
Registered
2006 ML320 CDi, 3.0-litre Diesel 7G-Tronic
Joined
·
8,925 Posts
Hello all,

I have a problem with the electric tailgate on my 2009 ML 320 cdi. W164 It opens fine but when shutting with either the tailgate button or keyfob often the tailgate goes down a few inches and then goes back up.

Any help with this issue would be appreciated

Thanks........Shaun.
Welcome to our forums Shaun.

sadly a common problem.

The lift pump in my W164 is under the spare wheel which is under the flap in the cargo floor. Lift out the tool trays and spare wheel.

Rain water gets in through faulty rear light cluster seals and corroded the wires to the lift pump.

I managed to repair them and the light ckuster seals but its best to replace of course if you're keeping the car.

Plus the fluid reservoir on the lift pump was completely empty (it could have been a leak but we didn't find one). It worked fine for a couple of months but almost emptied again and we think it's just air that needs bleeding out, there are no stains or visible weeps of fluid.

My mechie and I topped the reservoir up again and it sometimes works normally from all buttons - drivers door, tailgate and fob.

See this thread too if you can't get Benz Aeroshell 4 or 41 fluid:

 

·
Registered
2009 ML350 4matic: VIN 4JGBB86E59A491091
Joined
·
183 Posts
Hello all,

I have a problem with the electric tailgate on my 2009 ML 320 cdi. W164 It opens fine but when shutting with either the tailgate button or keyfob often the tailgate goes down a few inches and then goes back up.

Any help with this issue would be appreciated

Thanks........Shaun.
Welcome! Lots of info on this subject in our W164 forum Shaun. Over the course of the last few years, I've had to replace the lock actuator on my W164 and I also had to replace pinch sensors (both sides). On a scale of 1-10, I'm probably a 5 on the shadetree mechanic scale working out of my driveway so not too difficult of a task if you read other posts here and search out youtube.
 
1 - 5 of 5 Posts
Top