Mercedes-Benz Forum banner
1 - 12 of 12 Posts

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #1 ·
2001 ML 55 AMG, the wifes truck.
#1 the anti lock brake light comes on.
the dealer wants 600 bucks to fix it.
#2 we just put new pads and rotors on last year and at or around 19k they are both needing replaced again and 1300 bucks.
has anyone had the trbl with antilock, is it something that can be fixed?? and are the brake parts available to do it myself, is it worth messing around.
Rich
 

·
Registered
2020 MB GLE 450 4MATIC, 2015 BMW M4
Joined
·
2,167 Posts
RE: ML 55 brake woes

Richie_Rich - 1/26/2005 8:44 PM

2001 ML 55 AMG, the wifes truck.
#1 the anti lock brake light comes on.
the dealer wants 600 bucks to fix it.
#2 we just put new pads and rotors on last year and at or around 19k they are both needing replaced again and 1300 bucks.
has anyone had the trouble with antilock, is it something that can be fixed?? and are the brake parts available to do it myself, is it worth messing around.
Rich
I don't know why V8s go through brakes so much faster than 6s, but they seem to. You could save quite a bit doing it yourself. Mail order parts (Clair or others). There are plenty of online resources. Doesn't take great mechanical skills or specialized tools (except for bleeding).

Here's a lot of DIY info:
http://www.whnet.com/4x4/brakepads.html

No clue on the anti-lock issue. What does he say the problem is?
 

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #3 ·
yes I just priced them and can save alot. I am a weekend mech and this is a no brainer for me. I just never wanted to touch the thing but the price gougging on parts and labor is rediculous. the anti lock they were going to reset the computer but that the unit was defective. all of this just 3k after warranty.
Rich
 

·
Registered
2020 MB GLE 450 4MATIC, 2015 BMW M4
Joined
·
2,167 Posts
Richie_Rich - 1/26/2005 9:35 PM

2004.5 Dodge Ram 3500 4x4 cummins diesel
2005 KZ 41kx2 toy hauler (43' of fith wheel)
2001 ML 55 AMG
2001 Excursion 7.3 PSD (just sold) :(
1976 Jeep J-10 4x4 401 v8 (tweaked a bit)
1956 Willys DJ 2 wheel drive
1951 Willys M38 4x4 (engine transplant)
All those vehicles and no "car?"
 

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #5 ·
we have up the cars (lexus, infinity and Bmer) when we started going up to our cabin, cars just don't fill the tab for us. however I am looking into building up a fab5 1967 cobra with a 427 in it. thats if I finish the sand jeep.
Rich
 

·
Premium Member
05 500
Joined
·
6,647 Posts
Is the ABS functioning at all - try braking hard on slippery surface.

Simply becasue the ABS light is on doesn't mean there's no ABS. Typical example, sometimes the BAS, ESP, ABS would come on becasue of faulty brake switch while all three functions are working just fine.
 

·
Registered
ML 270CDI 2002, BMW K1300S, VW POLO 1.9TDI
Joined
·
515 Posts
"Simply becasue the ABS light is on doesn't mean there's no ABS".
---------------------------------------

If the ABS lights up and stays on whilst driving this indicates that there is a fault in the ABS system and that the ABS has been de-activated (4-ETS, BAS and ESP are also de-activated).....you will still have normal brakes but without the anti-lock capability.
 

·
Registered
ML500, 2005
Joined
·
412 Posts
As pointed out by Darkmann, check the brake switch, tends to put the light on, brakes may be ok.
jd
 

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #9 ·
the stealer said the module was bad and wants 600 bucks to fix it. they reset the computer to erase the code but who knows when it will come back. this all happened when I was out of town and it was raining real bad, could something have shorted out??
Rich
 

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #10 ·
I ordered all the parts from autohaus az 407.00 bucks
I am having a local garage that a friend takes their benz too and trust fix the abs problem. the dealer ticket said it was a code 1000 and 1005 faulty control module. it couldn't have happened two thousand miles ago, I am not trying to be cheap I just don't like to give my money away either.
Rich
 

·
Member
'00 ML320 Elegance
Joined
·
8,965 Posts
jdanish - 1/27/2005 6:35 AM

As pointed out by Darkmann, check the brake switch, tends to put the light on, brakes may be ok.
jd
The wheel speed sensors can also set off the idiot lights. I had mine changed recently [:)]
 

·
Registered
2007 GL 450 Black on Black
Joined
·
55 Posts
Discussion Starter · #12 ·
update, turns out the light was from the sensor (one in back and the code was a control mod that just happen to go bad since the b service. the second shop did confirm this and we had it replaced by them. I got all of the parts from autohaus az, I did the rear pads only as that was all in need as indicated by the independant mb shop. the dealer wanted to slam me for all new pads and rotors. I did buy everything all new Brembo rotors and pads (forget the name of them) but the guy said they are good quality. the back pads took me about 1.5 hours start to finish. one thing for when I do the rotors does anyone know what size the nut is on the axel?thanks
also forgot the parts total was 407.00 to my door in 2 days dealer wants 1350.00 heres your sign..........
Rich
 
1 - 12 of 12 Posts
Top