Mercedes-Benz Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
:bowdown: thankyou for bothering to look at my post so, basically the car sometimes does not start ,and doesnt even work at all i mean it wont even open so i leave the car open at night and if i open a door maybe it will turn on or if it might start , drinks ABOUT AS MUCH ENGINE OIL AS DIESEL and the lighs may flash randomley. the official Mercedes dealership in my area doesnt know left from right , they just connect it to diagnostics and say its fixed . i have gone to a car expert whos okay with just about any car said to be honest you need a real mercedes specialist for this and ive spoke to mecedes specialists over the phone toengland and theyve said its the earth cable , but what to i can really doi dont know soany advice would be heavily appreciated .:bowdown:
 

·
Registered
1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Joined
·
7,035 Posts
I think what they are saying is to remove and clean the battery terminal connections, and clean the connection on that ground strap to the chassis. That ground strap needs god electrical connection to the chassis.

In other words, the telephone diagnosis is a poor battery/ground connection is causing your issue - when the connection is not right, that is why your car acts "dead", those connections could be loase and/or dirty, or both.

Keep the faith !
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
Sorry to hear about your problems.

You may need to to give the experts a bit more to go on like:

Model year
Your Location
Mileage of truck
A bit more background/history on the truck
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
sorry about my english in the post but i was half asleep when i wrote it , and fabbrisd1 thanks for the info ill check the battery/ground connection first thing tomorrow and really thanks .

@far888 , thanks for the reminder , its a 2006 model and im in pakistan right now and its a german spec but the mileage is a bit steep,around about 50000 kilometres . thanks
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
sorry about my english in the post but i was half asleep when i wrote it , and fabbrisd1 thanks for the info ill check the battery/ground connection first thing tomorrow and really thanks .

@far888 , thanks for the reminder , its a 2006 model and im in pakistan right now and its a german spec but the mileage is a bit steep,around about 50000 kilometres . thanks
Hello Kas,

You say you own a 2006 ML320???

Are you sure??

I ask because the ML320 became the ML350 (bigger engine) since 2003.

Further, IF you have a 2006 model it must be a W164 (new shape ML) and this forum is for the W163.

So maybe you should be asking your question on that section of the Forum.

Good luck!:thumbsup:
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
@far888 thanks for telling me it was inevitble anyways , it's just when I was looking for the ml section this came up . So I'm really sorry and I'll go the proper one and yes mike it is an ml320 cdi diesel , thanks cos for a minute there I got confused myself .

Goodbye and thank you fr all your help!
 
1 - 7 of 7 Posts
Top