Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Premium Member
2006 S350 SWB; 1991 300CE; MB diesel sprinter van; 1999 AMG-C43 (sold); 1978 450SLC (sold)
Joined
·
102 Posts
Discussion Starter #1
We are finally starting to drive the 78 450SLC regularly so I've been poking around the mechanicals more and more. I had the front end up to give a good look at the flex disks (they look almost new) but I noticed something odd with the exhaust.

I took the lower heat shields off to get a better look. There is no crossover pipe connecting the port and starboard downpipes, and I can see what looks like a washer/bolt combo welded in it's place. I never did get any service history on this car so everything is an adventure.

Anyway, this is what I've got. Any problems running this way? I do smell a faint exhaust smell sometimes at a stop light with windows down, so I'm sure I have a small leak, but I can't really hear it yet.
Todd
 

Attachments

·
Premium Member
2006 S350 SWB; 1991 300CE; MB diesel sprinter van; 1999 AMG-C43 (sold); 1978 450SLC (sold)
Joined
·
102 Posts
Discussion Starter #2
So after I've done some searching elsewhere it seems like the crossover pipe is pretty important for low and midrange performance. I've got to address the entire system anyway so I'll take care of it at that time.
 

·
Premium Member
2006 S350 SWB; 1991 300CE; MB diesel sprinter van; 1999 AMG-C43 (sold); 1978 450SLC (sold)
Joined
·
102 Posts
Discussion Starter #6
That's a shiny exhaust you've got there, thanks for the pic.

My shot is from below the mid driver side door looking towards the passenger front wheel. And you should see the crossover tube clearly, but of course it is not there.
Wonder why the PO took it off? I need to get this thing up on a shop lift to really get a good look.
Todd
 
1 - 6 of 6 Posts
Top