Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
1998 ML320 (W163)
Joined
·
270 Posts
Discussion Starter #1
I was looking in my fuse box for the door lock relays, and noticed I was missing other relays. I know for sure K6 and K13 were missing, I'll have to update the post when I get a chance to find out what other ones I'm missing. Should I just let relay K6 ride since I don't seem to be having any issues from not having it present?
 

·
Registered
1999 ML 430, 2001 ML55
Joined
·
652 Posts
First Check you fuse box cover diagram and make sure it is the one for your vehicle and read it in detail. There is no way that by missing any relay that pertains to your car everything would works. Makes no sense
 

·
W163 and General M Gremlin
Joined
·
3,695 Posts
I was looking in my fuse box for the door lock relays, and noticed I was missing other relays. I know for sure K6 and K13 were missing, I'll have to update the post when I get a chance to find out what other ones I'm missing. Should I just let relay K6 ride since I don't seem to be having any issues from not having it present?
lee,
An older related (short) discussion on the K6 for your year, 98.

As for the K13, here's an MB related short on the K13 (and yes, it was missing on some R129s) so
perhaps it may be related similarly to your situation.
 

·
Registered
1998 ML320 (W163)
Joined
·
270 Posts
Discussion Starter #4
I did read the first link earlier today. With the key in position 2, my ESP/BAS light does not come on at all. Would that be because I'm missing that relay? Also, I saw that it's a blue relay in every picture instead of a black one, would I have to use a blue one in its place or would it be safe to use a black one?

Sent from my OnePlus 7 Pro using Tapatalk
 

·
W163 and General M Gremlin
Joined
·
3,695 Posts
I did read the first link earlier today. With the key in position 2, my ESP/BAS light does not come on at all. Would that be because I'm missing that relay? Also, I saw that it's a blue relay in every picture instead of a black one, would I have to use a blue one in its place or would it be safe to use a black one?

Sent from my OnePlus 7 Pro using Tapatalk
What are the part#s of the respective relays?
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
68 Posts
I did read the first link earlier today. With the key in position 2, my ESP/BAS light does not come on at all. Would that be because I'm missing that relay? Also, I saw that it's a blue relay in every picture instead of a black one, would I have to use a blue one in its place or would it be safe to use a black one?

Sent from my OnePlus 7 Pro using Tapatalk
just note I've seen some videos on youtube where some people recommend to remove the relay just so they they get rid of a warning light! I wouldn't do it as it disables safety systems but some people do - could this be the case with yours? (previous owner?) etc.

the color (if buying aftermarket) I think don't matter so long as it does the same (look at the diagram on the side of the relay if same) - like normally close or normally open (not sure if this is correct terminology but hope it makes sense) or buy same using part number from photo below

- below is what I have for K6, its for ESP/brake lamp suppression on a 2001, check if same on 98, just wondering if your brake light work? I think this has something to do with that.
2643724
2643725


- I also don't have parking lamp left and right (k9 and k13 for 2001 AU) even though its there in the diagram but I think that is normal. Parking lamp left and right works ok - and I don't use it and no one uses it here anyway... (check diagram for your car as per Khomer2's suggestion)
 

·
Registered
Dallas, Texas
Joined
·
8,187 Posts
I did read the first link earlier today. With the key in position 2, my ESP/BAS light does not come on at all. Would that be because I'm missing that relay? Also, I saw that it's a blue relay in every picture instead of a black one, would I have to use a blue one in its place or would it be safe to use a black one?

Sent from my OnePlus 7 Pro using Tapatalk
MY98 does not have BAS/ESP.
 
  • Like
Reactions: argonlj

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
68 Posts
MY98 does not have BAS/ESP.
interesting

just for my future reference, where can we lookup specs for US delivered cars, tried kellybb doesn't seem to show all specs? thanks.

for overseas AU cars,we usually use redbook website. seems to indicate ESP/BAS is present for MY98 for AU cars, if this is not present on all MY98 then possibly redbook spec is incorrect :)

I understand specs are different per country, MY, etc etc

thank you.
 

·
Registered
Dallas, Texas
Joined
·
8,187 Posts
interesting

just for my future reference, where can we lookup specs for US delivered cars, tried kellybb doesn't seem to show all specs? thanks.

for overseas AU cars,we usually use redbook website. seems to indicate ESP/BAS is present for MY98 for AU cars, if this is not present on all MY98 then possibly redbook spec is incorrect :)

I understand specs are different per country, MY, etc etc

thank you.
Here is comparison of instrument display from OM MY98 and MY99.

 
  • Like
Reactions: argonlj

·
Registered
1998 ML320 (W163)
Joined
·
270 Posts
Discussion Starter #10
I've replaced all of the relays that were missing with relays from my parts car, with the exception of the blue K6 relay (it doesn't have it either). So far I haven't noticed anything suddenly working or even not working. What is the K6 relay even for? Is it's function important?

Sent from my OnePlus 7 Pro using Tapatalk
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
68 Posts
What is the K6 relay even for? Is it's function important?
K6 ESP/brake lamp suppression (on 2001, maybe different for 98 ) - I believe it prevents the brake light from lighting up (I could be wrong :) ) when ESP/BAS is working which MY98 doesn't have.

I personally prefer to have ESP/BAS for added safety, see this video or video (if unfamiliar with this system)

Since 98 doesn't have ESP/BAS, not having that K6 shouldn't matter (probably as designed, does not need one)
 

·
Registered
1998 ML320 (W163)
Joined
·
270 Posts
Discussion Starter #12
I find it odd that a 98 doesn't have it. There's a bulb in the gauge cluster for it and the decal is present from the factory. Hence why I was wondering if the light didn't come on because of the lack of a relay.

Also, forgive my ignorance on the subject but what exactly does the ESP/BAS do? What's different from the ETS system that a 1998 has?

Sent from my OnePlus 7 Pro using Tapatalk
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
68 Posts
not easy (unless someone else knows an easy way)
or may even be not possible
and probably not worth the $ you will need to do this even if possible
 
1 - 15 of 15 Posts
Top