Mercedes-Benz Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Ok so here is the problem.
I have a 2006 Mercedes S500, it would go in reverse but would go in drive sometimes and sometimes would just get stuck in neutral. So I took it to a independent Mercedes shop they diagnose it and say transmission is good with no shavings and oil is clean its valve body problem. So I bought the valve body from another mercedes dealer because I have a friend there and gave me a good price on it and I called sangera mercedes here in bakersfield they told me $285 for labor when I got there they changed the price to $485. So they check tranny say oil is clean and no scrapings so they said its valve body tranny is good and they installed it, and come to find out it was wrong valve body that mercedes gave me so I go get the right one and they charge me another $485 to take it out and re install it. So I finally get the car done, and I take it and drive it. I drove it about 600 miles and the car stops on me 120 miles from where I live, so I tow it all the way back, they charge me $211 for labor and oil. After that I drive for 30 miles and the car stops again! So I take it back to the independent mercedes shop, they tell me mercedes didn't program it right and from me driving it on a non fully programed valve body I could of actually messed up the tranny. I tell the dealer that, and they tell me no we programmed it right, so im stuck without a car and in the middle with people telling me diffrent things please help what do I do?!?!?
 

·
Registered
10 Mercedes e350, 09 Mercedes GL450, 95 BMW 325IC, 89 Mercedes 260E, 84 Euro Mercedes 300D 4spd
Joined
·
645 Posts
it doesn't sound good at all,

what i would do, talk to GM of the Mercedes store, see if i can get some where,

also would mention that i would contact Mercedes of US with complain,

dealer do not like when customers complaint to the factory, because they have to maintain

sertant level of CSI and rest of the BS to get there bonuses, kick backs and etc.......,

last think i would do, is take them to court, and in USA can even be easier then rest of the world
 

·
Registered
93 500E/04 C240/15 GLK 250
Joined
·
205 Posts
s500

Ok so here is the problem.
I have a 2006 Mercedes S500, it would go in reverse but would go in drive sometimes and sometimes would just get stuck in neutral. So I took it to a independent Mercedes shop they diagnose it and say transmission is good with no shavings and oil is clean its valve body problem. So I bought the valve body from another mercedes dealer because I have a friend there and gave me a good price on it and I called sangera mercedes here in bakersfield they told me $285 for labor when I got there they changed the price to $485. So they check tranny say oil is clean and no scrapings so they said its valve body tranny is good and they installed it, and come to find out it was wrong valve body that mercedes gave me so I go get the right one and they charge me another $485 to take it out and re install it. So I finally get the car done, and I take it and drive it. I drove it about 600 miles and the car stops on me 120 miles from where I live, so I tow it all the way back, they charge me $211 for labor and oil. After that I drive for 30 miles and the car stops again! So I take it back to the independent mercedes shop, they tell me mercedes didn't program it right and from me driving it on a non fully programed valve body I could of actually messed up the tranny. I tell the dealer that, and they tell me no we programmed it right, so im stuck without a car and in the middle with people telling me diffrent things please help what do I do?!?!?

I think your Fu***d. They are just going to give you the runaround until you are sick of all the BS. Tell them you want to test drive a new car & drive it through their front window.
 

·
Registered
10 Mercedes e350, 09 Mercedes GL450, 95 BMW 325IC, 89 Mercedes 260E, 84 Euro Mercedes 300D 4spd
Joined
·
645 Posts
I think your Fu***d. They are just going to give you the runaround until you are sick of all the BS. Tell them you want to test drive a new car & drive it through their front window.
or just drive it home, instead of the window,
 

·
Registered
2000 S430 156k (11/12)
Joined
·
507 Posts
There are some good articles about the valve body at the W220 S-CLASS ENCYCLOPEDIA at the top of the forum, search through those.
What's the mileage? Can you also be more specific as to what's happening after the replacement.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,667 Posts
pretty small mileage to hav a serious tranny problem
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
Ok so here is the problem.
I have a 2006 Mercedes S500, it would go in reverse but would go in drive sometimes and sometimes would just get stuck in neutral. So I took it to a independent Mercedes shop they diagnose it and say transmission is good with no shavings and oil is clean its valve body problem. So I bought the valve body from another mercedes dealer because I have a friend there and gave me a good price on it and I called sangera mercedes here in bakersfield they told me $285 for labor when I got there they changed the price to $485. So they check tranny say oil is clean and no scrapings so they said its valve body tranny is good and they installed it, and come to find out it was wrong valve body that mercedes gave me so I go get the right one and they charge me another $485 to take it out and re install it. So I finally get the car done, and I take it and drive it. I drove it about 600 miles and the car stops on me 120 miles from where I live, so I tow it all the way back, they charge me $211 for labor and oil. After that I drive for 30 miles and the car stops again! So I take it back to the independent mercedes shop, they tell me mercedes didn't program it right and from me driving it on a non fully programed valve body I could of actually messed up the tranny. I tell the dealer that, and they tell me no we programmed it right, so im stuck without a car and in the middle with people telling me diffrent things please help what do I do?!?!?
first off your car has a 722.9 trans, there is no way to incorrectly program the valve body. its either programmed or not programmed, its either snc coded or not scn coded, scn coded is done after the programming is done. also a new unit requires the transport protection to be removed, if any of these arent done, the car wouldnt come out of first gear. if it isnt scn coded the car will not start. so if you drove 600 miles everything was done correctly. i dont think you have your story straight on the issue. what do you mean you drove 600 miles then the car stopped???? then you were charged for labor and oil????? sounds fishy to me.
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
it doesn't sound good at all,

what i would do, talk to GM of the Mercedes store, see if i can get some where,

also would mention that i would contact Mercedes of US with complain,

dealer do not like when customers complaint to the factory, because they have to maintain

sertant level of CSI and rest of the BS to get there bonuses, kick backs and etc.......,

last think i would do, is take them to court, and in USA can even be easier then rest of the world
why do you benz owners always want to sue the dealer over the smallest shit????? based on this story here, the dealer is not at fault. the car was diagnosed at a independent shop, part purchased over the counter and then taken to the dealer for work, now after the work issues still happen and your blaming the dealer????? its funny how some of you are quick to blame the dealer for mistakes or want to sue and whine and complain about dumb shit.
 

·
Registered
2000 S430
Joined
·
16 Posts
why do you benz owners always want to sue the dealer over the smallest shit????? based on this story here, the dealer is not at fault. the car was diagnosed at a independent shop, part purchased over the counter and then taken to the dealer for work, now after the work issues still happen and your blaming the dealer????? its funny how some of you are quick to blame the dealer for mistakes or want to sue and whine and complain about dumb shit.
Note it says LAST THING. Now we dont have specifics on everything but im assuming if you were out of a car you believed sombody screwed up and denied it youd be mad too. Now he did say last as in if everything else doesnt work.
 

·
Premium Member
2002 S500, 1999 C230 Kompressor, 1997 C230
Joined
·
443 Posts
It really surprises me that the dealer would install a part that was not purchased from them. This is very unusual to say the least, and there are now too many parties involved to easily point the finger at anyone.

I would go to the shop that first diagnosed the condition and try to get the vehicle repaired with them, though I wonder: why didn't the first shop do the repair? Did the first shop decline service/repair because you wanted to bring in your own part?
 

·
Registered
2002 honda civic (sold), 2009 Mercedes ML350
Joined
·
1,344 Posts
the dealer installs parts all the time that customers bring in, they just have to pay labor. sometimes customers bring there own tires in that they got cheaper, own brake pads, own oil filter, etc..... but its a rare instance that an issue was diagnosed by one shop and brought to the dealer for the repair, its usually the other way around, diagnosed at the dealer and work done at the independent.
 

·
Premium Member
2002 S500, 1999 C230 Kompressor, 1997 C230
Joined
·
443 Posts
the dealer installs parts all the time that customers bring in, they just have to pay labor. sometimes customers bring there own tires in that they got cheaper, own brake pads, own oil filter, etc..... but its a rare instance that an issue was diagnosed by one shop and brought to the dealer for the repair, its usually the other way around, diagnosed at the dealer and work done at the independent.
The dealers in this area are pretty tight about letting in customer owned parts. Not really going to happen unless it is a line tires that they do not sell......but oddly enough, they have loaned me tools....I've never been able to figure out that logic!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #14
Ok im sorry im back to reply to everyone first one Streetglower the independent mechanic told me it was incorrectly programmed so no one is whining and crying, and yes I drove the car for about 600 miles then the car went in neutral and wont go in drive. I towed it to mercedes dealer and they charged me for flushing and refilling it with oil and charged me one hr of labor after they had put fresh oild 600 miles prior.

oceanliner part was bought from mercedes dealer just not the one that worked on it and the reason why the independent shop didnt work on it was because of the 7 speed tranny they cant program it nor can they put oil in it
 

·
Premium Member
2002 S500, 1999 C230 Kompressor, 1997 C230
Joined
·
443 Posts
Ok im sorry im back to reply to everyone first one Streetglower the independent mechanic told me it was incorrectly programmed so no one is whining and crying, and yes I drove the car for about 600 miles then the car went in neutral and wont go in drive. I towed it to mercedes dealer and they charged me for flushing and refilling it with oil and charged me one hr of labor after they had put fresh oild 600 miles prior.

oceanliner part was bought from mercedes dealer just not the one that worked on it and the reason why the independent shop didnt work on it was because of the 7 speed tranny they cant program it nor can they put oil in it
Thanks for the clarifications, it sounds like you are in a situation that just won’t resolve. Please let us know how you finally got all of this repaired.
 

·
Registered
Joined
·
6 Posts
oceanliner part was bought from mercedes dealer just not the one that worked on it and the reason why the independent shop didnt work on it was because of the 7 speed tranny they cant program it nor can they put oil in it
Nor can they diagnose it properly either by the look of things.......:crybaby2:
 

·
Registered
2004 (w220) S500 & (R230) SL550 2007
Joined
·
646 Posts
sometimes cheap is expensive

It is not your job to be involved in getting the parts. The indie should have done the whole job. They even get a BIG discount you shouldn't be able to get from dealerships. Is this just an Indie? or are they BENZ experts that ONLY do BENZE'S?

My Indie is ONLY BENZ and let me tell you I let them do their job. They are as capable as the dealer, everyone there worked for the dealer before.
They have SDS and WIS and they are every bit as good as or better than the dealer.

You picked an indie that should not have been working on a Benz 7 speed, likely did'nt know how to replace the fluid and the dealer just sold the part number you asked for. Usually they want a VIN # to confirm exact part or they should have.

You tried to save a buck, picked a unqualified indie, got in the middle of the job and quite frankly are out of luck.

Most likely you will need a whole transmission, so get ready to write a check for about 5k to either a dealer or a Benz only indie. You might get lucky a get a transmission from a scrap yard if car was written off but still has servicable parts.

Good luck
 
1 - 17 of 17 Posts
Top