Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Since updating my iphone X to ios 13 and then 13.1.1 and 13.1.2 and now 13.2.2 the track information shown in the car is not refreshing the track information as it always has done.

The individual tracks still play correctly through the phone and the car, and the phone is showing the correct track it is playing, however, since loading the updates the Mercedes connect only shows the correct track for a few records and then appears to get stuck on a track and just show the information for that one track irrespective of what is actually playing

Hence you can constantly just see the one track it might have played hours before

Mercedes have updated my software in the car but say that they have only got ios up to version 11.2 which doesn't make sense as it has worked perfectly up to installing ios 13, worked great on ios 12 (i.e. showing every single track and its information as it is playing) since I have had the car

Mercedes customer service say 'I understand that this may be disappointing but I have conferred with our Technical Team who advise that Mercedes-Benz only support iOS 11.2., 11.1.2 at the moment' so don['t know what else to try

Does anyone have any ideas?
 

·
W221 & Audio Moderator
Joined
·
168 Posts
For what it is worth I just noticed my iPhone with. iOS write 13.3 no longer pairs with my Alpine head unit. There appears to be a change in the Bluetooth stack in iOS 13. I don’t have Bluetooth in my Mercedes so I cannot comment on that.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
For what it is worth I just noticed my iPhone with. iOS write 13.3 no longer pairs with my Alpine head unit. There appears to be a change in the Bluetooth stack in iOS 13. I don’t have Bluetooth in my Mercedes so I cannot comment on that.
For what it is worth I just noticed my iPhone with. iOS write 13.3 no longer pairs with my Alpine head unit. There appears to be a change in the Bluetooth stack in iOS 13. I don’t have Bluetooth in my Mercedes so I cannot comment on that.
Thanks for that, it’s so frustrating, there must be a solution, surely there must be loads of people having the same problem, just wish Mercedes would keep up with versions, they’re a worldwide company they shouldn’t be numerous versions behind, they must have a large technical team 😡
 

·
W221 & Audio Moderator
Joined
·
168 Posts
Thanks for that, it’s so frustrating, there must be a solution, surely there must be loads of people having the same problem, just wish Mercedes would keep up with versions, they’re a worldwide company they shouldn’t be numerous versions behind, they must have a large technical team 😡
I see your point and understand your frustration. I think the issue is a result of the suppliers that Mercedes-Benz acquires their Bluetooth module from. I am not sure if these are designed to be software upgradable or not using the Dealer Diagnostic Tool. If not, it unfortunately means a replacement may be the only remedy if a new SW version and HW version is released, or if Apple recognizes the software regression affecting the MB Bluetooth as well as at lease some Alpine headunits.
 
1 - 6 of 6 Posts
Top