Mercedes-Benz Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, I was wondering if anyone can help me troubleshoot a problem with my 2003 UK spec right hand drive c-class c220 diesel (W203 I believe)?

The car is fitted with xeon headlights but it's a complete lottery as to which light comes on - if at all. There seems to be no rhyme or reason as to what the problem is; one minute the left Xeon light starts, the next the right one starts and if I'm really lucky - they both will start together!

I understand this is a common fault that suggests the ballast (what is the ballast - and why's it called ballast!!?) needs replacing? I'm assuming the bulbs don't need replacing as they work - even if only occasionally.

If I switch the main lights off and on a few times without the engine running, they eventually both switch on.

If this is of any relevance - the car reports that the rear left light is out also and that it's switching to emergency lighting. If I check the rear bulbs - they are all working?

Trying to be logical here (I'm certainly not an electrician) - it seems like the rear bulb issue cause the front headlights to fail? Could it be that the front problem is caused by some sort of a variance in voltage around the lighting circuit caused at the rear light problem? I can't physically see any problems with the rear bulbs at all?

I know the ballast can be a very expensive replacement - having read other posts - but I don't want to go down that route if there maybe another cause.

Anyone got any suggestions or advice? :confused:

Thanks in advance!

Dave.
 
1 - 1 of 1 Posts
Top