Mercedes-Benz Forum banner

1 - 20 of 213 Posts

·
Registered
Joined
·
3 Posts
hi got a problem with my 308cdi.fault codes
1)1188 high pressure element shut off
2)1470 boost pressure converter
3)2006 prefeed pressure sensor
ps could all this be linked to leaking inmjectors?got a lot of carbon build up around the injectors!also how do you get the injectors out when they are seized in?made a slide hammer to hook under the injectors and this got two out but other two wont budge!!many thanks chris
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
As you havent said what the vehicle is doing or not doing.
I presume the vehicle is in limp mode (wont rev over 3000 rpm!
I would suggest removing the pipes and connectors from the boost sensor and clean the connectors and blow the pipes out.
Try reconnecting the the pipes and clearing the fault codes to see if they come up again.
If they do then you will have to replace the sensor & converter. (this is a common fault)
Let me know if you need further Advice, I am not an expert but have 10 of my own and my own diagnostic equip.of which I use to keep them on hte road.
 

·
Registered
Joined
·
128 Posts
i need help on the model # of transmision used in sprinter van to see if it would work in my320g 1991
engine /transmsion swap
hellllllllllllllp
 

·
Registered
Joined
·
12 Posts
Noisy Sprinter Engine

Hello there,

I have a 416 Motorhome with a noisy ratlle on the top end that comes and goes. It started at only 8,500 miles (out of warranty) at now is only 16,000 miles. Have serviced it and changed the oil to no avail can you help?

Trev
 

·
Registered
Joined
·
1 Posts
2002 Sprinter 308cdi semi auto

NEED HELP WITH YOUR CDI SPRINTER...DROP ME A LINE
Hi sprint fix i hope you can help this sprinter has had both lo & high pressure pumps replaced 3 new injectors and has no fault codes boost pressure and rail pressure is ok compression is even fuel variation is even will rev 4000rpm but wont pull up a hill but goes well on the flat scan tool is a bosch kts 520 starts and runs well.
Regards jva63.:surrender:
 

·
Registered
Joined
·
2 Posts
Hi we have a 2000 sprinter 313 cdi, which reading posts has gone into limp mode no rev over 3000k,can we just buy boost sensor and fit as this seems most likely cause or do we need to have fault codes read and reset as the could be some other cause, it's just only place local charges £65 alone just to diagnose and can not fit in for a week.

Thanks
for any replies
 

·
Registered
Joined
·
10,427 Posts
Hi we have a 2000 sprinter 313 cdi, which reading posts has gone into limp mode no rev over 3000k,can we just buy boost sensor and fit as this seems most likely cause or do we need to have fault codes read and reset as the could be some other cause, it's just only place local charges £65 alone just to diagnose and can not fit in for a week.

Thanks
for any replies
Do you mean MAF or boost pressure sensor, or something else?

Don't you have any independent workshop that would read the codes for less money?
 

·
Registered
Joined
·
2 Posts
Hi,
Thanks for reply, that is only independant workshop, i dont expect it for free but that is just to read code, no part of charge towards labour to fix etc.It was just if we could find out for sure and fit whatever part we needed ourselves without the wait or silly reading charge.
 

·
Registered
Joined
·
10,427 Posts
Hi,
Thanks for reply, that is only independant workshop, i dont expect it for free but that is just to read code, no part of charge towards labour to fix etc.It was just if we could find out for sure and fit whatever part we needed ourselves without the wait or silly reading charge.
Sounds high for reading the codes, our MB shop does not ask that much. Reading the codes was silly only if you can be sure about the faulty part otherwise. If you aren't, then you easily end up swapping good parts and spend even more money and time.

If you are sure it is one of the two, the car should start working fine without codes cleared. But it would be good to have the codes cleared anyway to help diagnosis next time, you would have a stored fault that may confuse diagnosis next time.
 

·
Registered
Joined
·
1 Posts
mb sprinter -00 213 cdi

problem is that engine shuts down when car is turned left. when stearing is turned straight engine starts again.
 

·
Registered
Joined
·
10,427 Posts
Have you checked the engine wiring harness. Any wires that move when steering? Any sensor that moves when steering turned? Short circuits do not have to be visible.
 

·
Registered
Joined
·
2 Posts
hi can you please help
I have a 313 2003reg and I keep getting air in the brakes I have put a new master cylinder on and there is no leaks I can find "looked over it about 20 times” does not lose any fluid when I bleed the brakes I get a ton of air out of rear drivers side takes about 5secounds to reach bleed nipple .when I bleed the brakes the pedal is spot on and then just goes down hill till there is nun left I have dun this 10 times all I can think is air is getting in the abs pump some how
can you please help
I cant seam to find a s/h one with the same code on it and I don’t really wont to buy a new one for £1300
 

·
Registered
Joined
·
137 Posts
Does anyone know what grade and type of oil should go into a sprintshift gearbox??
As MB just say they dont have a grade listed but do keep it on the shelf at £12/ltr and ill need 3.2ltrs!!!!!
 

·
Registered
Joined
·
7 Posts
Hi there just bought a 02 311 cdi and driving it i have noticed that it dosnt really boost till about 2,800 rpm but goes like mad after that. If i hit a hill it just dies in fifth and if i drive it and rev it out in every gear it ok. If i dont there dosnt seem to be the torque to pull it unloaded as well. I put my scanner on ot and got two heater plug light codes which it stays on about 1 min after start and goes out. Also P1470 code is this boost control sensor on the left hand side on the hose? Would this make it drive like this or is that the way these drive? I was also thinking about remapping to bring it up to 130-140bhp?? Anybody done this? Thanks in advance
 

·
Registered
Joined
·
1 Posts
sprinter 311cdi problem

Hi,my van drives perfectly,with plenty power.But every now and again it loses power and wont rev past 3000rpm.When left overnight it resumes back to normal again and could be ok for up to a week.Any advice would be very welcome.
 

·
Registered
Joined
·
11 Posts
hope you dont mind??

i know you said sprinter but i got a baby sprinter Vito 110 cdi year 2000
do you know what this fault code means
P1636 and p0600...
i just done the head gasket on her (dont mean just, it took me about 3 weeks??)
had 1 injector recon and it blowing out black smoke THICK.
had it plugged in last night and they where the only codes to come up..and something to do with high pressure sensor which i have now changed..and still black smoke. any help ...thanks in advance mate
ian
 

·
Registered
Joined
·
1 Posts
year 2000 313 cdi

hi all
can any one help,central locking and elec window on ns door stopped working have replaced loom in door but still no action backlight on the switch on drivers door is missing just on ns switch and no red led on central locking switch.....did have wierd problem with not starting until major pumping of brake pedal then you heard a click and all was ok this prob never returned
:confused:
 
1 - 20 of 213 Posts
Top