Mercedes-Benz Forum banner

Maybe time to take 1994 SL600 to the Stealer

3169 Views 21 Replies 8 Participants Last post by  MercedesTheBest
Took a break and now am going to start back on my SL600, either that or shoot it and put it out of her misery. It is still not running right, cuts out about 90mph and will not rev up over 4500rpm no power and shifts hard. Took it to acouple of indys who are suppose to be sharp with no real answers. The following is what has been done so far.
1-The injector harness is good( was replaced in 06)
2- Throttle bodies were rewired by Victor in NY
3-Rewired mass air flow sensors back to good wire
4-Removed injectors and cleaned them (they are working good)
5-New plugs
6-New fuel pump regulator
7-New fuel pumps and filter
8-New battery
9-New ignition module
The one indy had told me it was fuel pressure( that was why the pump,filter and regulator). Another said it was electrical. I have checked the injectors and I am getting voltage to the injectors and spark from the plugs. Neither one acted like the wanted any thing to do with the 600. If it is electrical after what I have done where do I start. Thank you in advance
1 - 8 of 22 Posts
Much of what you did was much needed at any rate. The TA wiring was horseshit, as was the MAF wiring. You can't expect the car to start to run right with that issue. At this point a scan might be appropriate. It's also worth checking the ASR switch in the accelerator pedal. It's just a micro switch that is on or off. If it doesn't work, you get no servo throttle. Another thing I'd check is with someone pushing the accelerator pedal and the engine running, make sure the throttle plate on the passengers side opens in sync with the drivers side. You might be running on the cable throttle only. Do not pull the cable by hand. That will most likely kick out the servo. You might need to take the rubber boot off to see the plate. This would be a wise experiment !
Glad you tried that. I suspected that you were not getting the slave (passenger side TA) online. Just for fun and giggles, you should check the ASR switch in the accelerator pedal. If that is not working, you will have only manual throttle (cable pulling the drivers side manual actuator linkage). There is a small harness that comes from the accelerator pedal up under the console. Check to make sure it works as it's supposed to. It is either no continuity or continuity. I have a new one I bought during my quest to repair my 600. If you need a pic or to verify when it's on or off, let me know.
The MAF provides air flow information to the fuel control system. In and of itself, it does not control the throttle body. The passengers side is slaved to the drivers side. Of course these are routed into the computer bay and controlled by the engine management computers.
A scan is a good thing to have. That was step one for me. It showed the drivers TA was bad (tuned out to be the bad wiring !). But at least you have a technical readout of whats happening with your car. If both throttles don't work, you only get the drivers working by the pull cable. And as you know, tranny shifts really hard and lets face it, driving a 6 isn't much fun for us V-12 guys ! :D

PS, make sure the pull cable has a touch of slack. If it pulls the linkage immediately, you can get get the LHM.
See less See more
I doubt that the suspension is affecting the ASR etc. The car's electronics communicate on a Car Area Network. (CAN) So if the programing sought to call for those parameters I suppose it could cause a issue, But I highly doubt that that's the case. Perhaps a fly by wire genius like Roncallo might have a thought. He pulled a complete M120 and all associated wiring and computers out of a Sl600 and stuffed them into a 107. That car of course has no hydraulic suspension. Therefore no sensors.
I grabbed the switch and interestingly enough they call it "switch accelerator control". I put an ohm meter on it and it is open when the pin in NOT depressed. When you press the pin it gives 993 ohms of resistance. So not a dead short as I thought ! Interesting. I felt the wiring on my car, it goes from near the top of the accelerator pedal then behind the panel on the drive line tunnel. As you can see the cable is fairly short. So perhaps you can chase that connection and test yours. Victor from New York had a video of him testing a SL500 TB. Unless he had a brick on the pedal when he moved the throttle arm manually, it kicked out. When he depressed the pedal enough to press that switch, everything worked as advertised. That is what I postulated MAY be your current issue. Of course that would be too easy! Amongst all the other things, it's worth checking. Have you used the on board diagnostics in the computer bay to look for error codes ? And erased them ? Another worthwhile thing. Keep up the good work ! You are still around $ 124,000.00 to the good aren't you ? :D

PS, since you are not familiar with the 600, The accelerator pedal is feather light, and has very minute movement when all is well, that and it is way too easy to hit 88 mph and go back to the future :D If it feels like you are driving a 1956 GMC truck, the fly by wire servo throttles are NOT working. You are driving with manual cable throttle on the passengers side 6 cylinders. That's the Limp Home Mode. Generally makes a lot of things limp :D


See less See more
Sounds like that's working correctly. I'll have to see if mine has that much pedal travel before the switch trips. Sure was worth a try. Others have reported this as a fix. My thought has been work thru the most common issues one at a time. I assume your TA's were a wiring mess and you repaired that. Did you check the TA plug ins to make sure a pin didn't push a compaion receptical out ? Sure seems like a connection issue somewhere. The bitch about all the nasty wiring issues is that shorts in the TA wiring can cause other issues or damage. Let's hope that's not the case ! Although I haven't had mine out, I've read that their are fuses in a couple of the computer modules. You might do a search. Seems with bad wiring that could be an issue. Also worth checking is the condition of the harness that the TA's attach to on the fender well harness. You might make a slit in that sheath and make sure that's not roached. That's rare, but is known to happen.
Since is doesn't work from the moment of startup, I'd forget things like wheel sensors etc. Are you getting the ASR light on the dash? Or check engine light ?
See less See more
Interesting. That explains no servo throttle. At this point I think my next step would be to identify that module, pull it out and see if it has an accessible fuse. Secondly clean the contacts and see if that makes any difference. I suppose that the module can simply be damaged by the bad TA wiring. Or simply not receiving power. I think you are on a good path !
At the risk of repeating myself, WHAT THE HECK IS GOING ON ? :D
Light weight :D. I suppose you wouldn't be willing to share the rest of your $ 125,000.00 repair budget with the rest of us 600 owners ? Seriously, Sorry the car proved to be too far gone. :crybaby2: Hopefully the next guy can breath some life in it. Glad you had a bit of camaraderie here in the 129 forum. I for one enjoyed the attempt to make the car work for you. See you on the 107 side !
1 - 8 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.