Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I seem to have a major issue and not sure what the cause of it is. I have a 2002 C240. It came stock with 16 inch tires. I upgraded and bought 17 AMG rims with Michelin XGT H4 tires 225/45 R 17. I have only driven on these tires for 14,000 miles and the tread is almost gone. 3 questions on this please

1) why would the tread go so fast on a 4 door sedan that barely has any power? I had a sports car before and the tires lasted 25,000 miles. This does not make sense

2)what tire can I buy next that would give me tread that would last a long time and is also a relaible and safe tire? please be very specific on this so I can purchase the tire

3)I have had my front tires pumped with 32psi while the rear pumped with 35psi, is that correct?

Please any feed back anyone can offer I would really appreciate. Im sooooo pissed off because those tires cost money and they barely lasted 14,000 when they should last around 40,000 to 50,000. Thank you all for your time in advance
 

·
BenzWorld Tire & Wheel God
Joined
·
1,386 Posts
the XGT H4 has had many reports of excessive wear over the years and since the technolog...

the XGT H4 has had many reports of excessive wear over the years and since the technology in all tires has been improved since that tire was introduced ... you can easily get a better performing tire that last longer today ....

http://www.tirerack.com/a.jsp?a=CQ4&url=/tires/index.jsp
 
1 - 3 of 3 Posts
Top