Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
I have searched and read many of the threads on similar issues, none the same.
Recent oil and filter change < 1000kms. Oil 20/50 as before. Ambient temps in Perth are 34 - 41C.
Engine temp runs at around 90C. Oil pressure @ 3 bars @ start and acceleration. Once warmed used to fall to 1 bar @ lights and off gas. Idle around 750.
Now, cold and off gas, still @ 3bars, but once warmed, @ lights and off gas drops to half a bar. Idle @ 500-750, no shaking/rattle.
What is going on?. Any insight appreciated.
 

·
Registered
Joined
·
6,118 Posts
It has to peg 3 bar by 1500RPM, mine pegs at 1100RPM.
 

·
Registered
Joined
·
468 Posts
Oil pressure gauge sender is probably going causing this. Just replaced mine due to same condition and now hot idle oil pressure reads 1-1.5 bar and pops right up to 3 bar just off idle.
 

·
Registered
Joined
·
261 Posts
I have searched and read many of the threads on similar issues, none the same.
Recent oil and filter change < 1000kms. Oil 20/50 as before. Ambient temps in Perth are 34 - 41C.
Engine temp runs at around 90C. Oil pressure @ 3 bars @ start and acceleration. Once warmed used to fall to 1 bar @ lights and off gas. Idle around 750.
Now, cold and off gas, still @ 3bars, but once warmed, @ lights and off gas drops to half a bar. Idle @ 500-750, no shaking/rattle.
What is going on?. Any insight appreciated.
I don't see anything wrong. According to the manual, that's an overpressure gauge. As long as the reading is over 0, and it jumps to 3 when you're at 1500-2000rpm, everything is ok, IMHO.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #6
Thanks for the input. I notice that +/- 1100 it hits 3bars, and stays there, until off gas and revs fall again.
The filter is MAHLE. The old one was not. I am not sure what the last one was. From the searches, I thought that these filters were OK, Am I wrong??
I checked the engine bay again, NO oil leaks, strange smells and the oil level is ok..
flavio81, thanks for the reassurance, but I am still a little jittery when it comes to this motor. Should I change to another filter or relax?
 

·
Registered
Joined
·
6,118 Posts
I think the manual says it can drop to .5 bar but must rise to 3 bar atleast by 1500RPM. If its at 3 by 1500RPM then don't worry about it. If you want you could turn your idle up alittle so the needle will come up alittle and you won't be so worried.
 

·
Registered
Joined
·
261 Posts
I think the manual says it can drop to .5 bar but must rise to 3 bar atleast by 1500RPM. If its at 3 by 1500RPM then don't worry about it. If you want you could turn your idle up alittle so the needle will come up alittle and you won't be so worried.
Right on.
 
1 - 8 of 8 Posts
Top